summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-11-11 00:13:16 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-11-13 07:55:23 +0100
commit24f607267f72e06771a5a034a93ade42f887d929 (patch)
treee239c24c223f01d1424e79ddb392d2a43b746bce /recipes-bsp
parentef8280b3d393e1b849a9de4293c86db14f311977 (diff)
cbootimage/imx-loader/mtd-utils/tegrarcm: fix 32-bit build of our bsp/devtools
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/cbootimage/cbootimage.bb3
-rw-r--r--recipes-bsp/tegrarcm/tegrarcm.bb3
2 files changed, 6 insertions, 0 deletions
diff --git a/recipes-bsp/cbootimage/cbootimage.bb b/recipes-bsp/cbootimage/cbootimage.bb
index 9cf6705..66e5594 100644
--- a/recipes-bsp/cbootimage/cbootimage.bb
+++ b/recipes-bsp/cbootimage/cbootimage.bb
@@ -15,6 +15,9 @@ PV = "1.4"
EXTRA_OEMAKE='PREFIX="${prefix}" LIBDIR="${libdir}"'
+#we want cbootimage binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
+EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -m32' 'BUILDDIR=${S}'"
+
S = "${WORKDIR}/git"
inherit autotools
diff --git a/recipes-bsp/tegrarcm/tegrarcm.bb b/recipes-bsp/tegrarcm/tegrarcm.bb
index 0180a36..b4aedb6 100644
--- a/recipes-bsp/tegrarcm/tegrarcm.bb
+++ b/recipes-bsp/tegrarcm/tegrarcm.bb
@@ -15,6 +15,9 @@ PV = "1.6"
EXTRA_OEMAKE='PREFIX="${prefix}" LIBDIR="${libdir}"'
+#we want tegrarcm binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
+EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32'"
+
do_compile () {
oe_runmake CPPFLAGS=-I${includedir}/cryptopp || die "make failed"
}