summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/cbootimage/cbootimage.bb3
-rw-r--r--recipes-bsp/tegrarcm/tegrarcm.bb3
-rw-r--r--recipes-devtools/imx-loader/imx-loader_git.bb5
-rw-r--r--recipes-devtools/mtd/mtd-utils_%.bbappend2
4 files changed, 9 insertions, 4 deletions
diff --git a/recipes-bsp/cbootimage/cbootimage.bb b/recipes-bsp/cbootimage/cbootimage.bb
index 9cf6705..66e5594 100644
--- a/recipes-bsp/cbootimage/cbootimage.bb
+++ b/recipes-bsp/cbootimage/cbootimage.bb
@@ -15,6 +15,9 @@ PV = "1.4"
EXTRA_OEMAKE='PREFIX="${prefix}" LIBDIR="${libdir}"'
+#we want cbootimage binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
+EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -m32' 'BUILDDIR=${S}'"
+
S = "${WORKDIR}/git"
inherit autotools
diff --git a/recipes-bsp/tegrarcm/tegrarcm.bb b/recipes-bsp/tegrarcm/tegrarcm.bb
index 0180a36..b4aedb6 100644
--- a/recipes-bsp/tegrarcm/tegrarcm.bb
+++ b/recipes-bsp/tegrarcm/tegrarcm.bb
@@ -15,6 +15,9 @@ PV = "1.6"
EXTRA_OEMAKE='PREFIX="${prefix}" LIBDIR="${libdir}"'
+#we want tegrarcm binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
+EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32'"
+
do_compile () {
oe_runmake CPPFLAGS=-I${includedir}/cryptopp || die "make failed"
}
diff --git a/recipes-devtools/imx-loader/imx-loader_git.bb b/recipes-devtools/imx-loader/imx-loader_git.bb
index 95fb7f2..07915f9 100644
--- a/recipes-devtools/imx-loader/imx-loader_git.bb
+++ b/recipes-devtools/imx-loader/imx-loader_git.bb
@@ -13,9 +13,8 @@ S = "${WORKDIR}/git/"
PR = "r1"
-#we want mkfs.ubifs binary to run on a 32 bit architecture, on x86-64 this requires the 32 bit compatibility libs
-#FIXME: this does not work, currently we have to compile the 32bit binary on a 32bit machine
-#EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR -m32' 'BUILDDIR=${S}'"
+#we want imx_usb binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
+EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32'"
BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/mtd/mtd-utils_%.bbappend b/recipes-devtools/mtd/mtd-utils_%.bbappend
index 91e4c8f..5c74edb 100644
--- a/recipes-devtools/mtd/mtd-utils_%.bbappend
+++ b/recipes-devtools/mtd/mtd-utils_%.bbappend
@@ -1,3 +1,3 @@
#EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'BUILDDIR=${S}'"
-#we want mkfs.ubifs binary to run on a 32 bit architecture, on x86-64 this requires the 32 bit compatibility libs
+#we want mkfs.ubifs binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR -m32' 'BUILDDIR=${S}'"