summaryrefslogtreecommitdiff
path: root/recipes-bsp/cbootimage/cbootimage.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/cbootimage/cbootimage.bb')
-rw-r--r--recipes-bsp/cbootimage/cbootimage.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-bsp/cbootimage/cbootimage.bb b/recipes-bsp/cbootimage/cbootimage.bb
index 9cf6705..66e5594 100644
--- a/recipes-bsp/cbootimage/cbootimage.bb
+++ b/recipes-bsp/cbootimage/cbootimage.bb
@@ -15,6 +15,9 @@ PV = "1.4"
EXTRA_OEMAKE='PREFIX="${prefix}" LIBDIR="${libdir}"'
+#we want cbootimage binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
+EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -m32' 'BUILDDIR=${S}'"
+
S = "${WORKDIR}/git"
inherit autotools