summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot_%.bbappend')
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
new file mode 100644
index 0000000..fcd3a4d
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}//files:"
+DEPENDS:append:apalis-tk1 = " cbootimage-native"
+
+SRC_URI:append:apalis-tk1 = " \
+ file://apalis-tk1.img.cfg \
+ file://fw_env.config \
+ file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
+"
+
+do_deploy:append:apalis-tk1() {
+ cd ${DEPLOYDIR}
+ cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
+ cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
+ rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
+}