summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot_%.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-11-10 11:32:06 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-11-16 14:17:55 +0100
commit4b16683eff6d9f190e38df1e3d85b9e113687623 (patch)
tree317bcb0a30e7098865758e2e5936b1a014336449 /recipes-bsp/u-boot/u-boot_%.bbappend
parentdf9d271552339d13a874351204053beddf2801b1 (diff)
apalis-tk1: use mainline u-boot
Mainline (sources.denx.de) has all the functionality needed for Apalis TK1. Build directly from the mainline repo. Add a bbappend which makes the cboot image format. Related-to: ELB-4090 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot_%.bbappend')
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
new file mode 100644
index 0000000..fcd3a4d
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}//files:"
+DEPENDS:append:apalis-tk1 = " cbootimage-native"
+
+SRC_URI:append:apalis-tk1 = " \
+ file://apalis-tk1.img.cfg \
+ file://fw_env.config \
+ file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
+"
+
+do_deploy:append:apalis-tk1() {
+ cd ${DEPLOYDIR}
+ cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
+ cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
+ rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
+}