summaryrefslogtreecommitdiff
path: root/recipes-bsp/tegrastats
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-01-04 13:45:49 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 19:03:31 +0100
commitab205d9308f3f869432d002412a0b11e28606696 (patch)
tree70094628d1f1a53840c62553d81f4f498081be89 /recipes-bsp/tegrastats
parentb86261ad84a017494219d4e8d6be3162d674ab6d (diff)
apalis/colibri-t20 -t30: drop machines
These machines use an old Nvidia provided downstream kernel 3.1.10. They are no longer compatible with more recent sysroot components, e.g. libc, xserver et. al. The maintenance burden to keep the userspace components in their old version becomes simply too high. Keep using the rocko based 2.8 BSP for these machines. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/tegrastats')
-rwxr-xr-xrecipes-bsp/tegrastats/files/Tegrastats-gtk.desktop11
-rwxr-xr-xrecipes-bsp/tegrastats/files/apalis-tk1/tegrastatsbin80941 -> 0 bytes
-rwxr-xr-xrecipes-bsp/tegrastats/files/tegrastatsbin19320 -> 80941 bytes
-rwxr-xr-xrecipes-bsp/tegrastats/files/tegrastats-gtkbin15200 -> 0 bytes
-rw-r--r--recipes-bsp/tegrastats/tegrastats.bb24
5 files changed, 5 insertions, 30 deletions
diff --git a/recipes-bsp/tegrastats/files/Tegrastats-gtk.desktop b/recipes-bsp/tegrastats/files/Tegrastats-gtk.desktop
deleted file mode 100755
index 5424c2a..0000000
--- a/recipes-bsp/tegrastats/files/Tegrastats-gtk.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/usr/bin/env xdg-open
-
-[Desktop Entry]
-Version=1.0
-Type=Application
-Terminal=false
-Icon[C]=gnome-monitor.png
-Exec=/usr/bin/tegrastats-gtk
-Name[C]=Tegrastats-gtk
-Name=Tegrastats-gtk
-Icon=gnome-monitor.png
diff --git a/recipes-bsp/tegrastats/files/apalis-tk1/tegrastats b/recipes-bsp/tegrastats/files/apalis-tk1/tegrastats
deleted file mode 100755
index 22a42cf..0000000
--- a/recipes-bsp/tegrastats/files/apalis-tk1/tegrastats
+++ /dev/null
Binary files differ
diff --git a/recipes-bsp/tegrastats/files/tegrastats b/recipes-bsp/tegrastats/files/tegrastats
index 5f76593..22a42cf 100755
--- a/recipes-bsp/tegrastats/files/tegrastats
+++ b/recipes-bsp/tegrastats/files/tegrastats
Binary files differ
diff --git a/recipes-bsp/tegrastats/files/tegrastats-gtk b/recipes-bsp/tegrastats/files/tegrastats-gtk
deleted file mode 100755
index 53d250d..0000000
--- a/recipes-bsp/tegrastats/files/tegrastats-gtk
+++ /dev/null
Binary files differ
diff --git a/recipes-bsp/tegrastats/tegrastats.bb b/recipes-bsp/tegrastats/tegrastats.bb
index 0718a5d..d1bc364 100644
--- a/recipes-bsp/tegrastats/tegrastats.bb
+++ b/recipes-bsp/tegrastats/tegrastats.bb
@@ -1,35 +1,21 @@
SUMMARY = "NVIDIAS tegrastats"
-DESCRIPTION = "NVIDIAS tegrastats in a commandline version and one with output to a gtk title bar, gives information about cpu use"
+DESCRIPTION = "NVIDIAS tegrastats gives information about cpu use for TK1"
LICENSE = "CLOSED"
PR = "r3"
-SRC_URI = " \
- file://tegrastats \
- file://tegrastats-gtk \
- file://Tegrastats-gtk.desktop \
-"
+SRC_URI = "file://tegrastats"
S = "${WORKDIR}"
-PACKAGES_prepend = "${PN}-gtk "
-
# Inhibit warnings about files being stripped.
# Inhibit warnings about missing DEPENDS, Files are provided in binary form"
INSANE_SKIP_${PN} = "already-stripped build-deps file-rdeps ldflags"
-INSANE_SKIP_${PN}-gtk = "already-stripped build-deps file-rdeps"
-
do_install() {
- install -d ${D}${bindir}/ ${D}/home/root/Desktop/
+ install -d ${D}${bindir}
install -m 0755 ${S}/tegrastats* ${D}${bindir}/
- install -m 0755 ${S}/Tegrastats-gtk.desktop ${D}/home/root/Desktop/
}
-FILES_${PN}-gtk = " \
- ${bindir}/tegrastats-gtk \
- /home/root/Desktop/Tegra* \
-"
-
FILES_${PN} = "${bindir}/tegrastats"
-
-PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "tegra124"