summaryrefslogtreecommitdiff
path: root/recipes-bsp/tegrastats/tegrastats.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/tegrastats/tegrastats.bb')
-rw-r--r--recipes-bsp/tegrastats/tegrastats.bb24
1 files changed, 5 insertions, 19 deletions
diff --git a/recipes-bsp/tegrastats/tegrastats.bb b/recipes-bsp/tegrastats/tegrastats.bb
index 0718a5d..d1bc364 100644
--- a/recipes-bsp/tegrastats/tegrastats.bb
+++ b/recipes-bsp/tegrastats/tegrastats.bb
@@ -1,35 +1,21 @@
SUMMARY = "NVIDIAS tegrastats"
-DESCRIPTION = "NVIDIAS tegrastats in a commandline version and one with output to a gtk title bar, gives information about cpu use"
+DESCRIPTION = "NVIDIAS tegrastats gives information about cpu use for TK1"
LICENSE = "CLOSED"
PR = "r3"
-SRC_URI = " \
- file://tegrastats \
- file://tegrastats-gtk \
- file://Tegrastats-gtk.desktop \
-"
+SRC_URI = "file://tegrastats"
S = "${WORKDIR}"
-PACKAGES_prepend = "${PN}-gtk "
-
# Inhibit warnings about files being stripped.
# Inhibit warnings about missing DEPENDS, Files are provided in binary form"
INSANE_SKIP_${PN} = "already-stripped build-deps file-rdeps ldflags"
-INSANE_SKIP_${PN}-gtk = "already-stripped build-deps file-rdeps"
-
do_install() {
- install -d ${D}${bindir}/ ${D}/home/root/Desktop/
+ install -d ${D}${bindir}
install -m 0755 ${S}/tegrastats* ${D}${bindir}/
- install -m 0755 ${S}/Tegrastats-gtk.desktop ${D}/home/root/Desktop/
}
-FILES_${PN}-gtk = " \
- ${bindir}/tegrastats-gtk \
- /home/root/Desktop/Tegra* \
-"
-
FILES_${PN} = "${bindir}/tegrastats"
-
-PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "tegra124"