summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-toradex-ti_6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-toradex-ti_6.1.bb')
-rw-r--r--recipes-kernel/linux/linux-toradex-ti_6.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex-ti_6.1.bb b/recipes-kernel/linux/linux-toradex-ti_6.1.bb
index b7d5957..bfb25aa 100644
--- a/recipes-kernel/linux/linux-toradex-ti_6.1.bb
+++ b/recipes-kernel/linux/linux-toradex-ti_6.1.bb
@@ -3,6 +3,8 @@ SUMMARY = "Linux kernel for Toradex TI based modules"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-${PV}:"
+
SRC_URI = " \
git://git.toradex.com/linux-toradex.git;protocol=https;branch=${SRCBRANCH};name=machine \
"
@@ -53,3 +55,19 @@ KBUILD_DEFCONFIG ?= "toradex_defconfig"
# We need to pass it as param since kernel might support more then one
# machine, with different entry points
KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
+
+###############################################################################
+# Apply the RT patch and change the configuration to use PREMPT_RT when the
+# preempt-rt override is set.
+###############################################################################
+
+# patches get moved into the 'older' directory when superseeded, so provide
+# both possible storage locations.
+MIRRORS:append:preempt-rt = "${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.15/older/ ${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.15/"
+SRC_URI:append:preempt-rt = " \
+ ${KERNELORG_MIRROR}/linux/kernel/projects/rt/6.1/older/patch-6.1.46-rt13.patch.xz;name=rt-patch \
+ file://preempt-rt.scc \
+ file://preempt-rt-less-latency.scc \
+"
+
+SRC_URI[rt-patch.sha256sum] = "df29cf27bb7ef0b7750f541d959b791905a5d41a322896f9a4bb57b5ab00f202"