summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index a280e6e..7d2aba3 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -14,13 +14,15 @@ SRC_URI:append:k3 = " \
file://weston.ini \
"
+OURFILEPATH = "${@d.getVar("UNPACKDIR") or '${WORKDIR}'}"
+
do_install:append:k3 () {
install -d ${D}${bindir}
- install -m 755 ${WORKDIR}/runWeston ${D}${bindir}
+ install -m 755 ${OURFILEPATH}/runWeston ${D}${bindir}
install -d ${D}${sysconfdir}/profile.d
- install -m 0644 ${WORKDIR}/weston.ini ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/wayland_env.sh ${D}${sysconfdir}/profile.d/
+ install -m 0644 ${OURFILEPATH}/weston.ini ${D}${sysconfdir}
+ install -m 0644 ${OURFILEPATH}/wayland_env.sh ${D}${sysconfdir}/profile.d/
if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then
sed -i -e "/^\[core\]/a xwayland=true" ${D}${sysconfdir}/xdg/weston/weston.ini