summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-02-16 18:04:13 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2023-02-22 14:43:59 +0100
commitb9b9c2a195a66622ab80f24b507acbe6acfcd937 (patch)
tree0ec82af4656c260b7d04dc514f91f4247e19f654 /recipes-bsp
parentfb1479811929d0f787cab72b4741497efbaa5fa8 (diff)
u-boot-toradex-ti-staging: verdin-am62: build for our target and add dfu
Change from building the U-Boot am62x-sdk target to verdin-am62. Additionally build the R5 DFU SPL and deploy it. Note the u-boot-initial-env no longer gets deleted due to the use of UBOOT_CONFIG. Thus the deployment of u-boot-initial-env got simplified. Related-to: ELB-5045 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb b/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
index 7e2df76..4bed82d 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
@@ -27,11 +27,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
# preserve and deploy u-boot-initial-env if building for the Cortex-A53 core
# even if u-boot-ti.inc do_deploy() tries to delete it.
-do_compile:append () {
- cp ${B}/u-boot-initial-env ${B}/u-boot-initial-env.preserved
-}
-
-DEPLOY_INITIAL_ENV = "install -D -m 644 ${B}/u-boot-initial-env.preserved ${DEPLOYDIR}/${UBOOT_INITIAL_ENV} || true"
+DEPLOY_INITIAL_ENV = "install -D -m 644 ${B}/sd/u-boot-initial-env ${DEPLOYDIR}/ || true"
DEPLOY_INITIAL_ENV:k3r5 = ":"
do_deploy:append () {
${DEPLOY_INITIAL_ENV}