summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-05-17 15:42:35 +0200
committerFrancesco Dolcini <francesco.dolcini@toradex.com>2023-06-05 09:51:23 +0000
commitbd2c37f1f41f1ed3273cc3e1bce0108df3cda522 (patch)
treedb4eb55688f098fdc34b91b90ea31c5d1365bd89
parent27b82cb882d310caf7e4695d21f795aaef295d3c (diff)
weston-init: add xwayland packageconfig
If both x11 and wayland are in DISTRO_FEATURE add xwayland to weston.ini. Related-to: ELB-5190 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend10
1 files changed, 9 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 8c6ab12..05a45eb 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -2,7 +2,11 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
PR:append:am62xx = ".arago12"
-PACKAGECONFIG:append:am62xx:tdx = " no-idle-timeout"
+PACKAGECONFIG:append:am62xx:tdx = " \
+ no-idle-timeout \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland','', d)} \
+"
+PACKAGECONFIG[xwayland] = ",,"
SRC_URI:append:am62xx = " \
file://runWeston \
@@ -17,6 +21,10 @@ do_install:append:am62xx () {
install -d ${D}${sysconfdir}/profile.d
install -m 0644 ${WORKDIR}/weston.ini ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/wayland_env.sh ${D}${sysconfdir}/profile.d/
+
+ if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then
+ sed -i -e "/^\[core\]/a xwayland=true" ${D}${sysconfdir}/xdg/weston/weston.ini
+ fi
}
FILES:${PN}:append:am62xx = "${sysconfdir}/profile.d/* ${sysconfdir}/weston.ini"