summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-04-24 09:28:21 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-04-27 14:57:42 +0200
commit90a96e77cf75149bbcb8e727144c1c3e871f3c1d (patch)
tree441375928ebade51161ed8e675e29fccb14c3b6d
parent46a093c2e2de9427ce1abb0c1979a518973e15e5 (diff)
verdin-am62: fix gp/hs-fs/hs-se handling
meta-ti changed to additionally handle HS-FS and HS-SE devices, i.e. to provide tiboot3 for the different flavours of the SoC. They added a multiconfig for each of the flavours also renaming stuff for the gp device we use. Follow the change to have GP build again, but opt out of additionally building tiboot3 for HS-FS and HS-SE devices. meta-ti commit 12bb9e20 ("machine: Add AM62x HS-SE evm configuration") commit 053002fb ("am62xx-evm: Add AM62x HS-FS evm configuration") Related-to: ELB-5170 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--conf/machine/verdin-am62-k3r5-gp.conf (renamed from conf/machine/verdin-am62-k3r5.conf)0
-rw-r--r--conf/machine/verdin-am62.conf7
-rw-r--r--recipes-bsp/dfu-metadata/dfu-metadata_0.1.bb2
3 files changed, 8 insertions, 1 deletions
diff --git a/conf/machine/verdin-am62-k3r5.conf b/conf/machine/verdin-am62-k3r5-gp.conf
index 29e3461..29e3461 100644
--- a/conf/machine/verdin-am62-k3r5.conf
+++ b/conf/machine/verdin-am62-k3r5-gp.conf
diff --git a/conf/machine/verdin-am62.conf b/conf/machine/verdin-am62.conf
index 6e27797..a641468 100644
--- a/conf/machine/verdin-am62.conf
+++ b/conf/machine/verdin-am62.conf
@@ -9,6 +9,13 @@ MACHINE_FEATURES:remove = "efi"
require conf/machine/verdin-am62.inc
require conf/machine/include/am62xx.inc
+# override what am62xx.inc sets for a hs-fs/hs-se variant so that only
+# the gp variant is built and deployed and is the default.
+BBMULTICONFIG:remove = "k3r5-hs-fs"
+BBMULTICONFIG:remove = "k3r5-hs-se"
+do_image_complete[mcdepends] = "mc::k3r5-gp:ti-sci-fw:do_deploy"
+IMAGE_BOOT_FILES:remove = "tiboot3-am62x-hs-evm.bin"
+
# Don't include kernels in standard images
RRECOMMENDS:${KERNEL_PACKAGE_NAME}-base = ""
diff --git a/recipes-bsp/dfu-metadata/dfu-metadata_0.1.bb b/recipes-bsp/dfu-metadata/dfu-metadata_0.1.bb
index 7b358c5..59fdb12 100644
--- a/recipes-bsp/dfu-metadata/dfu-metadata_0.1.bb
+++ b/recipes-bsp/dfu-metadata/dfu-metadata_0.1.bb
@@ -12,7 +12,7 @@ DFU_DEPLOYDIR = "${DEPLOYDIR}/${BPN}"
inherit deploy nopackages
DEPENDS = "bmap-tools-native dfu-util-native virtual/bootloader"
-do_deploy[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy"
+do_deploy[mcdepends] = "mc::k3r5-gp:ti-sci-fw:do_deploy"
do_deploy () {
install -d ${DFU_DEPLOYDIR}/recovery/bmaptools/