summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-02-21 20:42:52 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2023-02-22 17:54:18 +0100
commit8fd4be106c2aafa754bb4228bd953635d78fec20 (patch)
tree5be0cec766a5add1377565d6e00a01ba7714dd22
parent83f40ed141cef8c956717c23e2295d36482324a9 (diff)
verdin-am62.conf: fixup ddr timings to am62x-sk
This is to be reverted once we build for our Verdin AM62 module. Related-to: ELB-5045 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb b/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
index 4bed82d..0a9be22 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
@@ -33,6 +33,11 @@ do_deploy:append () {
${DEPLOY_INITIAL_ENV}
}
+# use the SK timings until we have our HW
+do_compile:prepend:k3r5 () {
+ cp ${S}/arch/arm/dts/k3-am62x-sk-ddr4-1600MTs.dtsi ${S}/arch/arm/dts/k3-am625-verdin-lpddr4-1600MTs.dtsi
+}
+
# build the k3r5 spl also for DFU
do_compile:append:k3r5 () {
if [ -L ${B}/${UBOOT_BINARY} ]; then