summaryrefslogtreecommitdiff
path: root/ecos/packages/devs/wallclock/freescale/kinetis/current
diff options
context:
space:
mode:
Diffstat (limited to 'ecos/packages/devs/wallclock/freescale/kinetis/current')
-rw-r--r--ecos/packages/devs/wallclock/freescale/kinetis/current/ChangeLog29
-rw-r--r--ecos/packages/devs/wallclock/freescale/kinetis/current/cdl/wallclock_kinetis_rtc.cdl70
-rw-r--r--ecos/packages/devs/wallclock/freescale/kinetis/current/src/wallclock_kinetis_rtc.cxx105
3 files changed, 204 insertions, 0 deletions
diff --git a/ecos/packages/devs/wallclock/freescale/kinetis/current/ChangeLog b/ecos/packages/devs/wallclock/freescale/kinetis/current/ChangeLog
new file mode 100644
index 0000000..a657124
--- /dev/null
+++ b/ecos/packages/devs/wallclock/freescale/kinetis/current/ChangeLog
@@ -0,0 +1,29 @@
+2011-04-24 Ilija Kocho <ilijak@siva.com.mk>
+
+ * cdl/wallclock_kinetis_rtc.cdl:
+ * src/wallclock_kinetis_rtc.cxx:
+ New wallclock driver
+
+//===========================================================================
+// ####GPLCOPYRIGHTBEGIN####
+// -------------------------------------------
+// This file is part of eCos, the Embedded Configurable Operating System.
+// Copyright (C) 2011 Free Software Foundation, Inc.
+//
+// This program is free software; you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation; either version 2 or (at your option) any
+// later version.
+//
+// This program is distributed in the hope that it will be useful, but
+// WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+// General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with this program; if not, write to the
+// Free Software Foundation, Inc., 51 Franklin Street,
+// Fifth Floor, Boston, MA 02110-1301, USA.
+// -------------------------------------------
+// ####GPLCOPYRIGHTEND####
+//===========================================================================
diff --git a/ecos/packages/devs/wallclock/freescale/kinetis/current/cdl/wallclock_kinetis_rtc.cdl b/ecos/packages/devs/wallclock/freescale/kinetis/current/cdl/wallclock_kinetis_rtc.cdl
new file mode 100644
index 0000000..4cbc595
--- /dev/null
+++ b/ecos/packages/devs/wallclock/freescale/kinetis/current/cdl/wallclock_kinetis_rtc.cdl
@@ -0,0 +1,70 @@
+# ====================================================================
+#
+# wallclock_kinetis_rtc.cdl
+#
+# eCos configuration data for Kinetis RTC
+#
+# ====================================================================
+## ####ECOSGPLCOPYRIGHTBEGIN####
+## -------------------------------------------
+## This file is part of eCos, the Embedded Configurable Operating System.
+## Copyright (C) 2011 Free Software Foundation, Inc.
+##
+## eCos is free software; you can redistribute it and/or modify it under
+## the terms of the GNU General Public License as published by the Free
+## Software Foundation; either version 2 or (at your option) any later
+## version.
+##
+## eCos is distributed in the hope that it will be useful, but WITHOUT
+## ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+## FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+## for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with eCos; if not, write to the Free Software Foundation, Inc.,
+## 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+##
+## As a special exception, if other files instantiate templates or use
+## macros or inline functions from this file, or you compile this file
+## and link it with other works to produce a work based on this file,
+## this file does not by itself cause the resulting work to be covered by
+## the GNU General Public License. However the source code for this file
+## must still be made available in accordance with section (3) of the GNU
+## General Public License v2.
+##
+## This exception does not invalidate any other reasons why a work based
+## on this file might be covered by the GNU General Public License.
+## -------------------------------------------
+## ####ECOSGPLCOPYRIGHTEND####
+# ====================================================================
+######DESCRIPTIONBEGIN####
+#
+# Author(s): ilijak
+# Contributors:
+# Date: 2011-04-23
+#
+#####DESCRIPTIONEND####
+#
+# ====================================================================
+
+cdl_package CYGPKG_DEVICES_WALLCLOCK_KINETIS_RTC {
+ display "Real-time clock"
+
+ description "Driver for the Kinetis RTC"
+
+ parent CYGPKG_IO_WALLCLOCK
+ active_if CYGPKG_IO_WALLCLOCK
+
+ compile wallclock_kinetis_rtc.cxx
+
+ implements CYGINT_WALLCLOCK_HW_IMPLEMENTATIONS
+ active_if CYGIMP_WALLCLOCK_HARDWARE
+ implements CYGINT_WALLCLOCK_SET_GET_MODE_SUPPORTED
+
+ cdl_option CYGIMP_WALLCLOCK_HARDWARE {
+ parent CYGPKG_IO_WALLCLOCK_IMPLEMENTATION
+ display "Hardware wallclock"
+ default_value 1
+ implements CYGINT_WALLCLOCK_IMPLEMENTATIONS
+ }
+}
diff --git a/ecos/packages/devs/wallclock/freescale/kinetis/current/src/wallclock_kinetis_rtc.cxx b/ecos/packages/devs/wallclock/freescale/kinetis/current/src/wallclock_kinetis_rtc.cxx
new file mode 100644
index 0000000..c4c0fb4
--- /dev/null
+++ b/ecos/packages/devs/wallclock/freescale/kinetis/current/src/wallclock_kinetis_rtc.cxx
@@ -0,0 +1,105 @@
+//==========================================================================
+//
+// wallclock_kinetis_rtc.cxx
+//
+// Wallclock implementation for Kinetis RTC module
+//
+//==========================================================================
+// ####ECOSGPLCOPYRIGHTBEGIN####
+// -------------------------------------------
+// This file is part of eCos, the Embedded Configurable Operating System.
+// Copyright (C) 2011 Free Software Foundation, Inc.
+//
+// eCos is free software; you can redistribute it and/or modify it under
+// the terms of the GNU General Public License as published by the Free
+// Software Foundation; either version 2 or (at your option) any later
+// version.
+//
+// eCos is distributed in the hope that it will be useful, but WITHOUT
+// ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+// FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+// for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with eCos; if not, write to the Free Software Foundation, Inc.,
+// 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+//
+// As a special exception, if other files instantiate templates or use
+// macros or inline functions from this file, or you compile this file
+// and link it with other works to produce a work based on this file,
+// this file does not by itself cause the resulting work to be covered by
+// the GNU General Public License. However the source code for this file
+// must still be made available in accordance with section (3) of the GNU
+// General Public License v2.
+//
+// This exception does not invalidate any other reasons why a work based
+// on this file might be covered by the GNU General Public License.
+// -------------------------------------------
+// ####ECOSGPLCOPYRIGHTEND####
+//==========================================================================
+//#####DESCRIPTIONBEGIN####
+//
+// Author(s): Ilija Kocho <ilijak@siva.com.mk>
+// Contributors:
+// Date: 2011-04-23
+// Purpose: Wallclock driver for Kinetis RTC module
+//
+//####DESCRIPTIONEND####
+//
+//==========================================================================
+
+#include <pkgconf/hal.h>
+#include <pkgconf/wallclock.h>
+#include <pkgconf/devices_wallclock_kinetis_rtc.h>
+
+#include <cyg/hal/hal_io.h>
+#include <cyg/hal/hal_intr.h>
+#include <cyg/infra/cyg_type.h>
+
+#include <cyg/io/wallclock.hxx>
+
+void
+Cyg_WallClock::init_hw_seconds(void)
+{
+ volatile cyghwr_hal_kinetis_rtc_t *rtc_p = CYGHWR_HAL_KINETIS_RTC_P;
+#ifdef CYGSEM_WALLCLOCK_SET_GET_MODE
+ // if RTC is disabled (e.g. due to power loss) initialize it.
+ if(!(rtc_p->sr &CYGHWR_HAL_KINETIS_RTC_SR_TCE))
+#endif
+ {
+ // halt clock, reset
+ rtc_p->sr &= ~CYGHWR_HAL_KINETIS_RTC_SR_TCE;
+ // set time
+ rtc_p->tpr = 0;
+ rtc_p->tsr = 0;
+ // restart clock
+ rtc_p->sr |= CYGHWR_HAL_KINETIS_RTC_SR_TCE;
+ }
+}
+
+cyg_uint32
+Cyg_WallClock::get_hw_seconds(void)
+{
+ volatile cyghwr_hal_kinetis_rtc_t *rtc_p = CYGHWR_HAL_KINETIS_RTC_P;
+
+ return rtc_p->tsr;
+}
+
+#ifdef CYGSEM_WALLCLOCK_SET_GET_MODE
+void
+Cyg_WallClock::set_hw_seconds(cyg_uint32 secs)
+{
+ volatile cyghwr_hal_kinetis_rtc_t *rtc_p = CYGHWR_HAL_KINETIS_RTC_P;
+
+ // halt clock, reset
+ rtc_p->sr &= ~CYGHWR_HAL_KINETIS_RTC_SR_TCE;
+ // set time
+ rtc_p->tpr = 0;
+ rtc_p->tsr = secs;
+ // restart clock
+ rtc_p->sr |= CYGHWR_HAL_KINETIS_RTC_SR_TCE;
+}
+#endif // CYGSEM_WALLCLOCK_SET_GET_MODE
+
+//==========================================================================
+// EOF wallclock_kinetis_rtc.cxx