summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-11-01 22:43:17 +0100
committerMax Krummenacher <max.oss.09@gmail.com>2015-03-31 21:50:34 +0200
commit2074c0d32474c07b5ae50a1112c387319da83ca5 (patch)
tree812a2f4854aba77124c8936e6884b5f4b4fefe64 /recipes
parentdcf001da829d182fd813d23f9675181dbfbc3062 (diff)
tegrastat: split out a GTK package
Diffstat (limited to 'recipes')
-rw-r--r--recipes/tegrastats/tegrastats.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/recipes/tegrastats/tegrastats.bb b/recipes/tegrastats/tegrastats.bb
index 38fd11d..76336a9 100644
--- a/recipes/tegrastats/tegrastats.bb
+++ b/recipes/tegrastats/tegrastats.bb
@@ -8,10 +8,12 @@ SRC_URI = "file://tegrastats \
S = "${WORKDIR}"
-PACKAGES = "${PN}"
+PACKAGES = "${PN} ${PN}-gtk"
# Inhibit warnings about files being stripped.
-INSANE_SKIP_${PN} = "already-stripped"
+# Inhibit warnings about missing DEPENDS, Files are provided in binary form"
+WARN_QA_remove = "already-stripped build-deps"
+WARN_QA-gtk_remove = "already-stripped build-deps"
do_install() {
install -d ${D}${bindir}/ ${D}/home/root/Desktop/
@@ -19,6 +21,8 @@ do_install() {
install -m 0755 ${S}/Tegrastats-gtk.desktop ${D}/home/root/Desktop/
}
-FILES_${PN} = " \
- ${bindir}/tegrastats* \
+FILES_${PN}-gtk = " \
+ ${bindir}/tegrastats-gtk \
/home/root/Desktop/Tegra* "
+
+FILES_${PN} = "${bindir}/tegrastats"