summaryrefslogtreecommitdiff
path: root/recipes/xorg-xserver
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-08-26 15:36:53 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-08-26 15:36:53 +0200
commit7abc17ec2dd0c443077cbc827ad1fadbe46657b0 (patch)
tree37fb4277fd4779b04778159dd9e7319b7c517a44 /recipes/xorg-xserver
parentb9347b96f08563fea09b39bf561ab162b5ee9bcd (diff)
xserver: move all xserver stuff in the same directoryT30_LinuxImageV2.0Beta3_20130820Apalis_T30_LinuxImageV2.0Beta2_20130816
Diffstat (limited to 'recipes/xorg-xserver')
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend b/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend
new file mode 100644
index 0000000..6bf44ff
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend
@@ -0,0 +1,23 @@
+# When Apalis T30 is used with a external NV graphics card, the binary
+# only driver fails (the dynamic linker can not resolve all symbols),
+# when xinerama is disabled in the X server
+
+# adapted from meta-fsl-arm/recipes-graphics/mesa/
+python __anonymous () {
+ import re
+
+ cur_machine = d.getVar('MACHINE', True)
+ if cur_machine == 'apalis-t30':
+ # Remove --disable-xinerama from EXTRA_OECONF
+ extra_oeconf = d.getVar('EXTRA_OECONF', True).split()
+ take_out = ['--disable-xinerama']
+ new_extra_oeconf = []
+ for i in extra_oeconf:
+ if i not in take_out:
+ new_extra_oeconf.append(i)
+
+ d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf))
+
+ # We are now machine specific
+ d.setVar('PACKAGE_ARCH', d.getVar('MACHINE_ARCH'))
+}