summaryrefslogtreecommitdiff
path: root/recipes/tegrastats
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-06-03 10:07:58 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2012-06-03 10:07:58 +0200
commitc1dd1f84dbee8ffe2db531a745bfc3b58c185fdb (patch)
treefdbf9f3561621082332a136d789b2326c50b7e8b /recipes/tegrastats
Initial commit
Diffstat (limited to 'recipes/tegrastats')
-rw-r--r--recipes/tegrastats/files/Makefile4
-rwxr-xr-xrecipes/tegrastats/files/tegrastatsbin0 -> 10000 bytes
-rw-r--r--recipes/tegrastats/tegrastats.bb26
-rw-r--r--recipes/tegrastats/tegrastats.bb~26
4 files changed, 56 insertions, 0 deletions
diff --git a/recipes/tegrastats/files/Makefile b/recipes/tegrastats/files/Makefile
new file mode 100644
index 0000000..7eb1f2d
--- /dev/null
+++ b/recipes/tegrastats/files/Makefile
@@ -0,0 +1,4 @@
+all:
+ echo "Hallo max"
+ $(CC) ${CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o tegrastats main.c
+ \ No newline at end of file
diff --git a/recipes/tegrastats/files/tegrastats b/recipes/tegrastats/files/tegrastats
new file mode 100755
index 0000000..1285d4d
--- /dev/null
+++ b/recipes/tegrastats/files/tegrastats
Binary files differ
diff --git a/recipes/tegrastats/tegrastats.bb b/recipes/tegrastats/tegrastats.bb
new file mode 100644
index 0000000..3d40f2b
--- /dev/null
+++ b/recipes/tegrastats/tegrastats.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "tegrastats, gives information about cpu use"
+LICENSE = "Nvidia propriatry"
+PR = "r1"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+#SRC_URI = "file://tegrastats \
+# "
+
+S = "${WORKDIR}/target-utils/tegrastats"
+
+SVN_REV = "230"
+SRC_URI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=target-utils/tegrastats;rev=${SVN_REV};proto=http"
+
+PACKAGES = "${PN}"
+
+#FILES_${PN} =
+
+do_compile() {
+ ${CC} -DNV_IS_LDK=1 ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} ${S}/main.c -o tegrastats
+}
+
+do_install() {
+ install -d ${D}/usr/bin
+ install -m 0755 ${S}/tegrastats ${D}/usr/bin
+}
diff --git a/recipes/tegrastats/tegrastats.bb~ b/recipes/tegrastats/tegrastats.bb~
new file mode 100644
index 0000000..58eb47a
--- /dev/null
+++ b/recipes/tegrastats/tegrastats.bb~
@@ -0,0 +1,26 @@
+DESCRIPTION = "tegrastats, gives information about cpu use"
+LICENSE = "Nvidia propriatry"
+PR = "r1"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+#SRC_URI = "file://tegrastats \
+# "
+
+S = "${WORKDIR}/target-utils/tegrastats"
+
+SVN_REV = 230
+SRC_URI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=target-utils/tegrastats;rev=${SVN_REV};proto=http"
+
+PACKAGES = "${PN}"
+
+#FILES_${PN} =
+
+do_compile() {
+ ${CC} -DNV_IS_LDK=1 ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} ${S}/main.c -o tegrastats
+}
+
+do_install() {
+ install -d ${D}/usr/bin
+ install -m 0755 ${S}/tegrastats ${D}/usr/bin
+}