summaryrefslogtreecommitdiff
path: root/recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2014-05-02 17:24:28 +0200
committerStefan Agner <stefan.agner@toradex.com>2014-05-02 17:24:28 +0200
commit30cb5bab2866b8ccc8703e6024b2db00a3da0104 (patch)
tree0c4b7b2e5702e4cfcdf1b85c7fb46c6e81f0cc98 /recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch
parent71427a7197e0956e44212aeae42d1fbf3398d56e (diff)
mcc-pingpong: demo application for ping pong with Cortex M4
Diffstat (limited to 'recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch')
-rw-r--r--recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch b/recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch
new file mode 100644
index 0000000..4e6b921
--- /dev/null
+++ b/recipes-support/mcc-pingpong/mcc-pingpong/makefile-use-libs.patch
@@ -0,0 +1,19 @@
+diff --git a/Makefile b/Makefile
+index 7a1fc14..a0f8f4a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,12 +1,12 @@
+ INSTALL_PATH=$(DESTDIR)/usr/bin
+
+-LDFLAGS+=-lmcc
++LDLIBS+=-lmcc
+
+ all: build/mcc-pingpong
+
+ build/mcc-pingpong: src/pingpong.c
+ mkdir -p build/
+- $(CC) $< -o $@ $(CFLAGS) $(LDFLAGS)
++ $(CC) $< -o $@ $(CFLAGS) $(LDLIBS) $(LDFLAGS)
+
+ install:
+ mkdir -p $(INSTALL_PATH)