summaryrefslogtreecommitdiff
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-10-17 14:40:26 +0200
committerMax Krummenacher <max.oss.09@gmail.com>2015-03-31 21:50:33 +0200
commit751e2780cd6cecbc54b32249204fd7314b347981 (patch)
tree0ca56c6ee5d86d50b89a458ee2fd77eb53df2764 /recipes-multimedia
parentb7e90d90fb9d8b30e64a37cb232a70139d4f6321 (diff)
libvpx: replace version with % wildcard
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/webm/libvpx_%.bbappend14
-rw-r--r--recipes-multimedia/webm/libvpx_0.9.5.bbappend2
-rw-r--r--recipes-multimedia/webm/libvpx_1.1.0.bbappend16
3 files changed, 14 insertions, 18 deletions
diff --git a/recipes-multimedia/webm/libvpx_%.bbappend b/recipes-multimedia/webm/libvpx_%.bbappend
new file mode 100644
index 0000000..0d9f8a7
--- /dev/null
+++ b/recipes-multimedia/webm/libvpx_%.bbappend
@@ -0,0 +1,14 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+#SRC_URI += "file://configure_remove_implicit_cflags.patch \
+# "
+
+#T20 does not have neon, but the armv7-linux-gcc assumes that the target has a neon unit
+VPXTARGET_armv7a_tegra2 = "armv6-linux-gcc"
+VPXTARGET_armv7a_qemuarm = "armv6-linux-gcc"
+
+CFLAGS_append_tegra3 = " -mfpu=neon -funsafe-math-optimizations -ftree-vectorize "
+CFLAGS_append_mx6 = " -mfpu=neon -funsafe-math-optimizations -ftree-vectorize "
+CONFIGUREOPTS += " --enable-runtime-cpu-detect "
diff --git a/recipes-multimedia/webm/libvpx_0.9.5.bbappend b/recipes-multimedia/webm/libvpx_0.9.5.bbappend
deleted file mode 100644
index e16bede..0000000
--- a/recipes-multimedia/webm/libvpx_0.9.5.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-CFLAGS_append = " -mfpu=neon -funsafe-math-optimizations -ftree-vectorize "
-CONFIGUREOPTS += " --enable-runtime-cpu-detect " \ No newline at end of file
diff --git a/recipes-multimedia/webm/libvpx_1.1.0.bbappend b/recipes-multimedia/webm/libvpx_1.1.0.bbappend
deleted file mode 100644
index e8c446e..0000000
--- a/recipes-multimedia/webm/libvpx_1.1.0.bbappend
+++ /dev/null
@@ -1,16 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-SRC_URI += "file://configure_remove_implicit_cflags.patch \
- "
-
-#T20 does not have neon, but the armv7-linux-gcc assumes that the target has a neon unit
-VPXTARGET_armv7a_colibri-t20 = "armv6-linux-gcc"
-#VPXTARGET_armv7a_colibri-t30 = "armv6-linux-gcc"
-#VPXTARGET_armv7a_apalis-t30 = "armv6-linux-gcc"
-VPXTARGET_armv7a_qemuarm = "armv6-linux-gcc"
-
-CFLAGS_append_colibri-t30 = " -mfpu=neon -funsafe-math-optimizations -ftree-vectorize "
-CFLAGS_append_apalis-t30 = " -mfpu=neon -funsafe-math-optimizations -ftree-vectorize "
-CONFIGUREOPTS += " --enable-runtime-cpu-detect " \ No newline at end of file