summaryrefslogtreecommitdiff
path: root/recipes-lxde
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2014-10-24 17:35:04 +0200
committerStefan Agner <stefan.agner@toradex.com>2014-10-24 17:35:04 +0200
commit1422d31c078fa9f8c75f692d66da91d2e667e5b7 (patch)
treef9fa31bcf7e6b3b5f5c0c6234ff03fe6667a64c5 /recipes-lxde
parent5c3257944157d65856969f188354377eca629718 (diff)
colibri_vf: detect module type on dt kernels
Detect the module type using the compatible property of the device tree to symlink the module specific background image.
Diffstat (limited to 'recipes-lxde')
-rw-r--r--recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend b/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend
index d22ad2f..7305cff 100644
--- a/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend
+++ b/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend
@@ -46,9 +46,12 @@ pkg_postinst_${PN}_vf () {
exit 1
fi
IS_VF50=`grep -c VF50 /proc/cpuinfo`
- if [ $IS_VF50 -gt 0 ]; then
+ IS_VF50_DTB=`grep -c toradex,vf500-colibri_vf50 /proc/device-tree/compatible`
+ IS_VF61=`grep -c VF61 /proc/cpuinfo`
+ IS_VF61_DTB=`grep -c toradex,vf610-colibri_vf61 /proc/device-tree/compatible`
+ if [ $IS_VF50 -gt 0 ] || [ $IS_VF50_DTB -gt 0 ]; then
ln -sf Wallpaper_ColibriVF50.png ${datadir}/lxde/wallpapers/toradex.png
- else
+ elif [ $IS_VF61 -gt 0 ] || [ $IS_VF61_DTB -gt 0 ]; then
ln -sf Wallpaper_ColibriVF61.png ${datadir}/lxde/wallpapers/toradex.png
fi
}