summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-07-26 20:24:02 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-09-22 11:09:16 +0200
commite1d1c86ee9f14c93100fc706c1a3f7db03a0301f (patch)
tree7e2558a6cafad336766fa0fa12adeccf922ebd15 /recipes-core
parentbb284933997c40ee86b4243e77f331d1b3fc6f7e (diff)
systemd: adapt to new systemd handling
with the move from meta-openembedded to oe-core some things have changed, e.g. the config files have to explicitly installed
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/fs-init/fs-init.bb3
-rw-r--r--recipes-core/usb-rndis/usb-rndis-systemd.bb3
2 files changed, 6 insertions, 0 deletions
diff --git a/recipes-core/fs-init/fs-init.bb b/recipes-core/fs-init/fs-init.bb
index b2b61a8..1a06a7e 100644
--- a/recipes-core/fs-init/fs-init.bb
+++ b/recipes-core/fs-init/fs-init.bb
@@ -16,6 +16,9 @@ do_compile () {
do_install () {
install -d ${D}/${sbindir}
install -m 0755 ${WORKDIR}/*.sh ${D}/${sbindir}
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/resizefs.service ${D}${systemd_unitdir}/system
}
NATIVE_SYSTEMD_SUPPORT = "1"
diff --git a/recipes-core/usb-rndis/usb-rndis-systemd.bb b/recipes-core/usb-rndis/usb-rndis-systemd.bb
index 5d18b7a..ec4f4cf 100644
--- a/recipes-core/usb-rndis/usb-rndis-systemd.bb
+++ b/recipes-core/usb-rndis/usb-rndis-systemd.bb
@@ -25,6 +25,9 @@ do_install() {
install -m 0755 ${WORKDIR}/start-rndis.sh ${D}/${bindir}/
install -m 0644 ${WORKDIR}/usb-rndis.rules ${D}/${sysconfdir}/udev/rules.d/
install -m 0644 ${WORKDIR}/udhcpd-usb-rndis.conf ${D}/${sysconfdir}/
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/usb-rndis.service ${D}${systemd_unitdir}/system
}
NATIVE_SYSTEMD_SUPPORT = "1"