summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-08-16 17:14:21 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-09-22 12:14:21 +0200
commit22d7dde1d9d183e2b2a6a610ade332837273a21b (patch)
treee91188a390760da7503499cec4f77b2ed79dfd1d /recipes-core
parentec9b0cb2c73325b12dc700ec6bcfbd6de2b69e5b (diff)
dropbear: fix moved path to sftp server
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/dropbear/dropbear_2012.55.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-core/dropbear/dropbear_2012.55.bbappend b/recipes-core/dropbear/dropbear_2012.55.bbappend
index 584ebba..3dd802e 100644
--- a/recipes-core/dropbear/dropbear_2012.55.bbappend
+++ b/recipes-core/dropbear/dropbear_2012.55.bbappend
@@ -7,3 +7,12 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
#embedded targets arn't usually in an environment where there
#is a reachable DNS server
SRC_URI += "file://remove-reverse-dns.patch"
+
+# Packport from http://patches.openembedded.org/patch/48957
+# workaround different libexecdir definition in oe; it does not fix
+# the multilib issues but mades sftp work again when dropbear and
+# openssh-sftp-server are for the same architecture.
+_sftp_server_path = "${@\
+ ['${libexecdir}/sftp-server','${libdir}/openssh/sftp-server']\
+ [d.getVar('libexecdir', True).endswith(d.expand('/${BPN}'))]}"
+CFLAGS += "-DSFTPSERVER_PATH=\\"${_sftp_server_path}\\""