summaryrefslogtreecommitdiff
path: root/recipes-core/fs-init/fs-init.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-06-24 09:36:23 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-06-26 14:05:14 +0200
commitbdca1beefc8cc510c0252b657983302dad1033d9 (patch)
tree626e81806cbcd75fba1d08d7509b8e0fb92a7fc2 /recipes-core/fs-init/fs-init.bb
parent540cc22ffd5104b52392cc5376045f8b3ba1d22e (diff)
fs-init: add recipe to extend rootfs partition on eMMC
- on Colbri/Apalis T30 the rootfs is downloaded in a minimum size. On first boot this filesystem is resized to fill its full partion. This slows down IO responsivness during the first 5 minutes.
Diffstat (limited to 'recipes-core/fs-init/fs-init.bb')
-rw-r--r--recipes-core/fs-init/fs-init.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-core/fs-init/fs-init.bb b/recipes-core/fs-init/fs-init.bb
new file mode 100644
index 0000000..b2b61a8
--- /dev/null
+++ b/recipes-core/fs-init/fs-init.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Script to expand the rootfs to the full size of its partion, started as a systemd service which removes itself once finished"
+LICENSE = "Public Domain"
+PR = "r3"
+
+SRC_URI = " \
+ file://resizefs.sh \
+ file://resizefs.service \
+ file://COPYING \
+"
+
+LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING;md5=1c3a7fb45253c11c74434676d84fe7dd"
+
+do_compile () {
+}
+
+do_install () {
+ install -d ${D}/${sbindir}
+ install -m 0755 ${WORKDIR}/*.sh ${D}/${sbindir}
+}
+
+NATIVE_SYSTEMD_SUPPORT = "1"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "resizefs.service"
+
+inherit allarch systemd