summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2015-05-04 18:08:22 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2015-05-12 10:06:07 +0200
commitd9fa6ad9ab81cd7f6fd5f50fd6650da774d0e1b4 (patch)
treeecffba8147ec61bcd4177413eff8aade7690ed8d /recipes-bsp
parent69d571635d6f030baa6a24367e917249ec91db7d (diff)
u-boot: use latest from git
While at it remove warning about stripped fw_printenv binary when building u-boot-toradex-fsl-fw-utils.
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb6
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb2
4 files changed, 8 insertions, 6 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
index 4f671e0..e4e5ed1 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
@@ -12,8 +12,8 @@ DEFAULT_PREFERENCE_colibri-imx6 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
-SRCREV_colibri-vf = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
-SRCREV_mx6 = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
+SRCREV_colibri-vf = "98ec78b1f28627e6d09972e2b1237c2ef8f161d9"
+SRCREV_mx6 = "98ec78b1f28627e6d09972e2b1237c2ef8f161d9"
SRCBRANCH_colibri-vf = "2015.04-toradex-next"
SRCBRANCH_mx6 = "2015.04-toradex-next"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
@@ -27,6 +27,8 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = 'CC="${CC}" STRIP="${STRIP}"'
+INSANE_SKIP_${PN} = "already-stripped"
+
inherit uboot-config
do_compile () {
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
index 78bc4ff..167740e 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
@@ -10,9 +10,9 @@ PR = "r0"
S = "${WORKDIR}/git"
-SRCREV_colibri-vf = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
+SRCREV_colibri-vf = "98ec78b1f28627e6d09972e2b1237c2ef8f161d9"
SRCBRANCH_colibri-vf = "2015.04-toradex-next"
-SRCREV_mx6 = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
+SRCREV_mx6 = "98ec78b1f28627e6d09972e2b1237c2ef8f161d9"
SRCBRANCH_mx6 = "2015.04-toradex-next"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index c32e239..655aa28 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -16,7 +16,7 @@ S="${WORKDIR}/git"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=2015.04-toradex-next"
SRC_URI += "file://fw_env.config"
# This revision is based on upstream "v2015.04"
-SRCREV = "d536cdbdf8e8765a2d223b2c38c0fa2e8ff36f12"
+SRCREV = "98ec78b1f28627e6d09972e2b1237c2ef8f161d9"
PV_apalis-t30 = "${PR}+gitr${SRCREV}"
PV_colibri-t20 = "${PR}+gitr${SRCREV}"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index d25788d..bcdd9b6 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -16,7 +16,7 @@ FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=2015.04-toradex-next"
# This revision is based on upstream "v2015.04"
-SRCREV = "d536cdbdf8e8765a2d223b2c38c0fa2e8ff36f12"
+SRCREV = "98ec78b1f28627e6d09972e2b1237c2ef8f161d9"
PV = "${PR}+gitr${SRCREV}"