summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2015-06-16 11:30:17 +0200
committerStefan Agner <stefan.agner@toradex.com>2015-06-16 15:29:51 +0200
commit2e1d9857985483788710913c8749f5d6bdc28826 (patch)
treebc2bcb4e12b57a6ac2098cdd7e229c2624168dab /recipes-bsp
parentae568dc9b001306a0723daccf3ea7912d94438ee (diff)
base-files/u-boot-toradex-fw-utils: move MMC unlock
The mmc unlock function causes troubles when using Poky reference distribution since Poky uses the busybox shell: /etc/rc5.d/S09xserver-nodm: /etc/profile.d/fw_unlock_mmc.sh: line 2: syntax error: unexpected "(" This avoids X getting at all. This patch does not solve the underlying problem, but works around it by moving the script to the u-boot-toradex-fw-utils recipe, which is not installed by the Poky images by default.
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/files/fw_unlock_mmc.sh6
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb8
2 files changed, 13 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/files/fw_unlock_mmc.sh b/recipes-bsp/u-boot/files/fw_unlock_mmc.sh
new file mode 100644
index 0000000..8982640
--- /dev/null
+++ b/recipes-bsp/u-boot/files/fw_unlock_mmc.sh
@@ -0,0 +1,6 @@
+# Give fw_setenv mmcblk0boot1 write permissions
+function fw_setenv() {
+ echo 0 > /sys/block/mmcblk0boot1/force_ro
+ /sbin/fw_setenv "$@"
+ echo 1 > /sys/block/mmcblk0boot1/force_ro
+}
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 4226958..029fc92 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -14,7 +14,8 @@ DEFAULT_PREFERENCE_colibri-t30 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=2015.04-toradex"
-SRC_URI += "file://fw_env.config"
+SRC_URI += "file://fw_env.config \
+ file://fw_unlock_mmc.sh"
# This revision is based on upstream "v2015.04"
SRCREV = "06ee8db6422e02337242e43b8573359443db59ea"
@@ -44,6 +45,11 @@ do_install () {
install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/
}
+do_install_append_tegra3() {
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0644 ${WORKDIR}/fw_unlock_mmc.sh ${D}${sysconfdir}/profile.d/fw_unlock_mmc.sh
+}
+
pkg_postinst_${PN}_colibri-t20 () {
# can't do this offline
if [ "x$D" != "x" ]; then