summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2015-01-03 14:55:19 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2015-05-12 10:04:33 +0200
commit197d5a8eda5294a393f30034684a4ac8873173d6 (patch)
tree71b1d8679ff64347e2ffd7154ac66f5a0c94ac37 /recipes-bsp
parent0377982881ca964e0bb24e6b006c3966f3e75544 (diff)
u-boot-fw-utils: fix compiler options
With dizzy we got compiler errors when compiling with the new 4.9 gcc.
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb1
2 files changed, 2 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
index fb9e40a..aba1031 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl-fw-utils_git.bb
@@ -26,7 +26,7 @@ PR = "r0"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
+EXTRA_OEMAKE = 'CC="${CC}"'
inherit uboot-config
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 5b301dd..cf74405 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -39,6 +39,7 @@ SRCREV_apalis-t30 = "${SRCREV_T30}"
S = "${WORKDIR}/git"
#actually this depend on the upstream U-Boot version and not on the machine
+CC_remove_tegra3 = "-mfpu=neon"
EXTRA_OEMAKE_tegra3 = 'CC="${CC}"'
EXTRA_OEMAKE_tegra2 = 'HOSTCC="${CC}" HOSTSTRIP="true"'