summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-03-04 15:32:49 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2013-03-04 15:32:49 +0100
commitde2c3085a24c36d5361d44890f0b5afdbee14cb7 (patch)
treee3efb091b9f5d68984ca1512578522f4ba9f1dc7
parent0422b8f87c7779c3e0a06bf0e99c7d30871ecc74 (diff)
remove unused files
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bbappend.orig23
-rw-r--r--recipes-kernel/linux/files/colibri-t20/bcm4329_warning.patch31
-rw-r--r--recipes-kernel/linux/files/colibri-t30/bcm4329_warning.patch33
-rw-r--r--recipes-kernel/linux/files/systemd-koen.patch48
-rw-r--r--recipes/images/trdx-extra.inc.orig52
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend.unused4
6 files changed, 0 insertions, 191 deletions
diff --git a/recipes-bsp/u-boot/u-boot_git.bbappend.orig b/recipes-bsp/u-boot/u-boot_git.bbappend.orig
deleted file mode 100644
index 9a1acc8..0000000
--- a/recipes-bsp/u-boot/u-boot_git.bbappend.orig
+++ /dev/null
@@ -1,23 +0,0 @@
-# Extends the core U-Boot GIT recipe
-# to take the u-boot sources including the colibri stuff from our git repository
-
-# Also overwries the license checksum to suit the updated text file in our U-Boot snapshot.
-#LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
-
-COMPATIBLE_MACHINE = "omap3-pandora"
-DEFAULT_PREFERENCE_omap3-pandora = "1"
-
-# Latest SRCREV.
-SRCREV_pn-${PN}_omap3-pandora = "55d0d2dd5d07fbfd57309997c38da5281b9824b5"
-
-PR ="r3"
-PV_omap3-pandora = "omap3-pandora+${PR}+gitr${SRCREV}"
-
-SRC_URI_omap3-pandora = "git://git.openpandora.org/pandora-u-boot.git;branch=pandora-2011.12;protocol=git \
-"
-
-UBOOT_MACHINE_omap3-pandora = "omap3_pandora_config"
-
-S = "${WORKDIR}/git"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-kernel/linux/files/colibri-t20/bcm4329_warning.patch b/recipes-kernel/linux/files/colibri-t20/bcm4329_warning.patch
deleted file mode 100644
index ba947bf..0000000
--- a/recipes-kernel/linux/files/colibri-t20/bcm4329_warning.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- kernel/drivers/net/wireless/bcm4329/dhd.h.orig 2012-05-31 08:58:04.000000000 +0200
-+++ kernel/drivers/net/wireless/bcm4329/dhd.h 2012-05-31 08:57:10.000000000 +0200
-@@ -1,3 +1,5 @@
-+#pragma GCC diagnostic warning "-Wunused-but-set-variable"
-+#pragma GCC diagnostic warning "-Warray-bounds"
- /*
- * Header file describing the internal (inter-module) DHD interfaces.
- *
---- kernel/drivers/net/wireless/bcm4329/siutils_priv.h 2012-05-31 08:57:01.000000000 +0200
-+++ kernel/drivers/net/wireless/bcm4329/siutils_priv.h.orig 2012-05-31 09:00:47.000000000 +0200
-@@ -1,3 +1,4 @@
-+#pragma GCC diagnostic warning "-Wunused-but-set-variable"
- /*
- * Include file private to the SOC Interconnect support files.
- *
---- kernel/drivers/net/wireless/bcm4329/dhd_linux.c.orig 2011-12-21 19:54:24.884526348 +0100
-+++ kernel/drivers/net/wireless/bcm4329/dhd_linux.c 2011-12-21 18:55:18.974476355 +0100
-@@ -1904,6 +1904,13 @@ dhd_open(struct net_device *net)
- ifidx = dhd_net2idx(dhd, net);
- DHD_TRACE(("%s: ifidx %d\n", __FUNCTION__, ifidx));
-
-+//max
-+ if (ifidx < 0 || ifidx >= DHD_MAX_IFS) {
-+ DHD_ERROR(("%s: Error: error ifidx out of range\n", __FUNCTION__));
-+ return -1;
-+ }
-+//end max
-+
- if ((dhd->iflist[ifidx]) && (dhd->iflist[ifidx]->state == WLC_E_IF_DEL)) {
- DHD_ERROR(("%s: Error: called when IF already deleted\n", __FUNCTION__));
- return -1;
diff --git a/recipes-kernel/linux/files/colibri-t30/bcm4329_warning.patch b/recipes-kernel/linux/files/colibri-t30/bcm4329_warning.patch
deleted file mode 100644
index d41c2ea..0000000
--- a/recipes-kernel/linux/files/colibri-t30/bcm4329_warning.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- kernel/drivers/net/wireless/bcm4329/dhd_linux.c.orig 2011-12-21 19:54:24.884526348 +0100
-+++ kernel/drivers/net/wireless/bcm4329/dhd_linux.c 2011-12-21 18:55:18.974476355 +0100
-@@ -1226,14 +1226,14 @@
- struct sk_buff *skb;
- uchar *eth;
- uint len;
-- void * data, *pnext, *save_pktbuf;
-+ void * data, *pnext/*max , *save_pktbuf*/;
- int i;
- dhd_if_t *ifp;
- wl_event_msg_t event;
-
- DHD_TRACE(("%s: Enter\n", __FUNCTION__));
-
-- save_pktbuf = pktbuf;
-+/*max save_pktbuf = pktbuf;*/
-
- for (i = 0; pktbuf && i < numpkt; i++, pktbuf = pnext) {
-
-@@ -1904,6 +1904,13 @@ dhd_open(struct net_device *net)
- ifidx = dhd_net2idx(dhd, net);
- DHD_TRACE(("%s: ifidx %d\n", __FUNCTION__, ifidx));
-
-+//max
-+ if (ifidx < 0 || ifidx >= DHD_MAX_IFS) {
-+ DHD_ERROR(("%s: Error: error ifidx out of range\n", __FUNCTION__));
-+ return -1;
-+ }
-+//end max
-+
- if ((dhd->iflist[ifidx]) && (dhd->iflist[ifidx]->state == WLC_E_IF_DEL)) {
- DHD_ERROR(("%s: Error: called when IF already deleted\n", __FUNCTION__));
- return -1;
diff --git a/recipes-kernel/linux/files/systemd-koen.patch b/recipes-kernel/linux/files/systemd-koen.patch
deleted file mode 100644
index 16b5bb9..0000000
--- a/recipes-kernel/linux/files/systemd-koen.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-http://dominion.thruhere.net/koen/cms/recommended-kernel-config-options-for-a-modern-angstrom-system
-old: -rw-r--r-- 1 mk users 3189608 1. Apr 22:14 git/arch/arm/boot/uImage
-new: -rw-r--r-- 1 mk users 3205580 28. Mai 11:43 git/arch/arm/boot/uImage
---- .config.orig 2012-05-28 11:14:29.000000000 +0200
-+++ .config 2012-05-28 11:25:25.000000000 +0200
-@@ -1,7 +1,7 @@
- #
- # Automatically generated make config: don't edit
- # Linux kernel version: 2.6.36.2
--# Sun Apr 1 17:06:26 2012
-+# Mon May 28 11:25:25 2012
- #
- CONFIG_ARM=y
- CONFIG_HAVE_PWM=y
-@@ -53,7 +53,10 @@
- CONFIG_POSIX_MQUEUE=y
- CONFIG_POSIX_MQUEUE_SYSCTL=y
- # CONFIG_BSD_PROCESS_ACCT is not set
--# CONFIG_TASKSTATS is not set
-+CONFIG_TASKSTATS=y
-+CONFIG_TASK_DELAY_ACCT=y
-+CONFIG_TASK_XACCT=y
-+CONFIG_TASK_IO_ACCOUNTING=y
- # CONFIG_AUDIT is not set
-
- #
-@@ -750,7 +753,8 @@
- # Generic Driver Options
- #
- CONFIG_UEVENT_HELPER_PATH=""
--# CONFIG_DEVTMPFS is not set
-+CONFIG_DEVTMPFS=y
-+CONFIG_DEVTMPFS_MOUNT=y
- CONFIG_STANDALONE=y
- CONFIG_PREVENT_FIRMWARE_BUILD=y
- CONFIG_FW_LOADER=y
-@@ -2137,9 +2141,9 @@
- CONFIG_INOTIFY_USER=y
- # CONFIG_QUOTA is not set
- # CONFIG_AUTOFS_FS is not set
--# CONFIG_AUTOFS4_FS is not set
-+CONFIG_AUTOFS4_FS=y
- CONFIG_FUSE_FS=y
--# CONFIG_CUSE is not set
-+CONFIG_CUSE=y
-
- #
- # Caches
diff --git a/recipes/images/trdx-extra.inc.orig b/recipes/images/trdx-extra.inc.orig
deleted file mode 100644
index 09d7d09..0000000
--- a/recipes/images/trdx-extra.inc.orig
+++ /dev/null
@@ -1,52 +0,0 @@
-#additional packages to include in our Toradex images
-
-#the following would build cross gdb
-#DEPENDS += "gdb-cross"
-
-#the gdb recipe provides gdbserver
-DEPENDS += "gdb"
-
-IMAGE_INSTALL += " alsa-utils \
- alsa-utils-aplay \
- alsa-utils-amixer \
- \
- \
- aspell \
- consolekit \
- sqlite3 \
- \
- curl \
- nfs-utils-client \
- openssh-scp \
- openssh-sftp \
- openssl-conf \
- ntpclient \
- pam-plugin-ck-connector \
- \
- bzip2 \
- gdbserver \
- grep \
- joe \
- ldd \
- mtd-utils \
- update-modules \
- \
- hdparm \
- iperf \
- memtester \
- stress \
- lmbench \
- nbench-byte \
- \
- tegrastats \
- trdx-nv-binaries \
- trdx-config \
- gpioconfig \
- \
- trdx-oak-sensors \
- "
-
-IMAGE_INSTALL_colibri-t20 += " \
- trdx-odm \
- "
-
diff --git a/recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend.unused b/recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend.unused
deleted file mode 100644
index 77e6079..0000000
--- a/recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend.unused
+++ /dev/null
@@ -1,4 +0,0 @@
-# Ugly temporary hack to have Xserver not segfaulting
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-SRC_URI += "file://xserver-instrumented.patch;pnum=2"