summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-02-03 14:15:06 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2014-02-04 10:59:00 +0100
commitb61db77becc96cfb597de8308fe891dd248f4945 (patch)
tree9f7dc102bd938d9ba19d6714b2694e8be9be5ce2
parent66d606a165f24f0f3c5eb1932205bceb94f43ad3 (diff)
util-linux: add fstrim
Add the fstrim utility to Colibri T30 image. The utility allows to send trim commands to the underlaying flash translation layer, which allows too free not used flash sectors and those improve wear- leveling
-rw-r--r--recipes-core/util-linux/util-linux_2.22.2.bbappend12
-rw-r--r--recipes/images/trdx-extra.inc23
2 files changed, 25 insertions, 10 deletions
diff --git a/recipes-core/util-linux/util-linux_2.22.2.bbappend b/recipes-core/util-linux/util-linux_2.22.2.bbappend
new file mode 100644
index 0000000..d3f8ca2
--- /dev/null
+++ b/recipes-core/util-linux/util-linux_2.22.2.bbappend
@@ -0,0 +1,12 @@
+#backport from master, util-linux: Add fstrim utility, commit ee3599472d7c5ccbf259312c7622b982941b6b1e
+
+PRINC := "${@int(PRINC) + 2}"
+
+PACKAGES =+ "util-linux-fstrim"
+FILES_util-linux-fstrim = "${base_sbindir}/fstrim"
+
+do_install_append () {
+ if [ -f "${D}${sbindir}/fstrim" ]; then
+ mv "${D}${sbindir}/fstrim" "${D}${base_sbindir}/fstrim"
+ fi
+}
diff --git a/recipes/images/trdx-extra.inc b/recipes/images/trdx-extra.inc
index 9526395..edeec6c 100644
--- a/recipes/images/trdx-extra.inc
+++ b/recipes/images/trdx-extra.inc
@@ -31,26 +31,25 @@ IMAGE_INSTALL_T20_T30 = " \
aspell \
"
-IMAGE_INSTALL_VF = " \
- iproute2 \
- canutils \
- mtd-utils-ubifs \
-"
-
-IMAGE_INSTALL_MACHINE_colibri-t20 = "${IMAGE_INSTALL_T20_T30} \
+IMAGE_INSTALL_MACHINE_colibri-t20 = " \
+ ${IMAGE_INSTALL_T20_T30} \
u-boot-fw-utils \
"
-IMAGE_INSTALL_MACHINE_colibri-t30 = "${IMAGE_INSTALL_T20_T30} \
+IMAGE_INSTALL_MACHINE_colibri-t30 = " \
+ ${IMAGE_INSTALL_T20_T30} \
fs-init \
+ util-linux-fstrim \
"
-IMAGE_INSTALL_MACHINE_apalis-t30 = "${IMAGE_INSTALL_T20_T30} \
+IMAGE_INSTALL_MACHINE_apalis-t30 = " \
+ ${IMAGE_INSTALL_T20_T30} \
pciutils \
iproute2 \
canutils \
lvds-ctrl \
fs-init \
+ util-linux-fstrim \
kernel-module-adv7180 \
kernel-module-max9526 \
kernel-module-tegra-v4l2-camera \
@@ -58,7 +57,11 @@ IMAGE_INSTALL_MACHINE_apalis-t30 = "${IMAGE_INSTALL_T20_T30} \
kernel-module-videobuf2-memops \
"
-IMAGE_INSTALL_MACHINE_colibri-vf = "${IMAGE_INSTALL_VF}"
+IMAGE_INSTALL_MACHINE_colibri-vf = " \
+ iproute2 \
+ canutils \
+ mtd-utils-ubifs \
+"
IMAGE_INSTALL_MACHINE = ""