summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2014-10-31 13:05:09 +0100
committerMax Krummenacher <max.oss.09@gmail.com>2014-10-31 13:05:09 +0100
commita49e673d0c468ddcca7dbab3417df695b1ba2eef (patch)
treea7f801da59a67c646f69a628aa3b19e77ca3ef1e
parentce9421b411ad663c6dfb4c26f87eca933a08cad8 (diff)
libcryptopp: package/stage to correct paths
The native build needs PREFIX to stage the files correctly into x86 sysroot The target build did not deploy the shared object due to missing soname version symlinks
-rw-r--r--recipes-support/libcryptopp/libcryptopp_5.6.2.bb20
1 files changed, 16 insertions, 4 deletions
diff --git a/recipes-support/libcryptopp/libcryptopp_5.6.2.bb b/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
index 25b1b69..606ce8e 100644
--- a/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
+++ b/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
@@ -25,9 +25,21 @@ inherit autotools pkgconfig
EXTRA_OECONF = "--libdir=${base_libdir}"
do_compile() {
- sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile
- export CXXFLAGS="${CXXFLAGS} -DNDEBUG -fPIC"
- oe_runmake -f GNUmakefile
- oe_runmake libcryptopp.so
+ sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile
+ export CXXFLAGS="${CXXFLAGS} -DNDEBUG -fPIC"
+ oe_runmake -f GNUmakefile
+ oe_runmake libcryptopp.so
}
+do_install_prepend() {
+ export PREFIX=${prefix}
+}
+
+do_install_append() {
+ if [ -f "${D}/usr/lib/libcryptopp.so" ] && [ ! -e "${D}/usr/lib/libcryptopp.so.${PV}" ]
+ then
+ mv ${D}/usr/lib/libcryptopp.so ${D}/usr/lib/libcryptopp.so.${PV}
+ ln -fs libcryptopp.so.${PV} ${D}/usr/lib/libcryptopp.so.5
+ ln -fs libcryptopp.so.${PV} ${D}/usr/lib/libcryptopp.so
+ fi
+}