summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-04-26 16:41:34 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-04-27 14:57:37 +0200
commitdd534f3120ffd2ed37d5fa00ff28524603cb8766 (patch)
treea7cd23d92becac8a2ebea10550a188a4564a5027 /recipes-bsp
parente270cf8bb1b0e8fc4a4a0dc576958b8ecd565d09 (diff)
alsa-state: fix overrides
Use the same override for fileoverride and SRC_URI:override. Otherwise a machine which sets the am62xx and tdx override would want to fetch the files but not find them in any of the paths searched. Only install the files for Dahlia and Development Carrier Board for a Verdin-AM62 so that other TI machines do not get their configuration messed up. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/alsa-state/alsa-state.bbappend4
-rw-r--r--recipes-bsp/alsa-state/alsa-state/am62xx/asound-dahlia.conf (renamed from recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dahlia.conf)0
-rw-r--r--recipes-bsp/alsa-state/alsa-state/am62xx/asound-dahlia.state (renamed from recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dahlia.state)0
-rw-r--r--recipes-bsp/alsa-state/alsa-state/am62xx/asound-dev.conf (renamed from recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dev.conf)0
-rw-r--r--recipes-bsp/alsa-state/alsa-state/am62xx/asound-dev.state (renamed from recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dev.state)0
5 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/alsa-state/alsa-state.bbappend b/recipes-bsp/alsa-state/alsa-state.bbappend
index 822ab1c..7ce42c1 100644
--- a/recipes-bsp/alsa-state/alsa-state.bbappend
+++ b/recipes-bsp/alsa-state/alsa-state.bbappend
@@ -12,7 +12,7 @@ SRC_URI:append:am62xx:tdx = " \
FILES:${PN} += "${sysconfdir}/asound-*.conf"
-do_install:append:am62xx:tdx () {
+do_install:append:verdin-am62:tdx () {
# Remove the default asound.conf, we need set up asound.conf dynamically
# at runtime to support both dev/dahlia boards.
rm -f ${D}${sysconfdir}/asound.conf
@@ -26,7 +26,7 @@ do_install:append:am62xx:tdx () {
pkg_postinst:${PN}:am62xx:tdx () {
}
-pkg_postinst_ontarget:${PN}:am62xx:tdx () {
+pkg_postinst_ontarget:${PN}:verdin-am62:tdx () {
if grep -q "Development" /proc/device-tree/model; then
board="dev"
else
diff --git a/recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dahlia.conf b/recipes-bsp/alsa-state/alsa-state/am62xx/asound-dahlia.conf
index b487974..b487974 100644
--- a/recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dahlia.conf
+++ b/recipes-bsp/alsa-state/alsa-state/am62xx/asound-dahlia.conf
diff --git a/recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dahlia.state b/recipes-bsp/alsa-state/alsa-state/am62xx/asound-dahlia.state
index cb4455b..cb4455b 100644
--- a/recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dahlia.state
+++ b/recipes-bsp/alsa-state/alsa-state/am62xx/asound-dahlia.state
diff --git a/recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dev.conf b/recipes-bsp/alsa-state/alsa-state/am62xx/asound-dev.conf
index 9a85c0f..9a85c0f 100644
--- a/recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dev.conf
+++ b/recipes-bsp/alsa-state/alsa-state/am62xx/asound-dev.conf
diff --git a/recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dev.state b/recipes-bsp/alsa-state/alsa-state/am62xx/asound-dev.state
index da26936..da26936 100644
--- a/recipes-bsp/alsa-state/alsa-state/verdin-am62/asound-dev.state
+++ b/recipes-bsp/alsa-state/alsa-state/am62xx/asound-dev.state