summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-02-06 11:03:37 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2023-02-13 14:43:52 +0100
commit3d3f03492053111e0205394c705ac6a276bcb252 (patch)
tree7c6984cf7cb1519385a2817ef5aa8d1c063a06e4 /recipes-bsp
parent051cd448cd0ae025911e5c7f272021b03b28dc31 (diff)
verdin-am62: prepare to have a tezi image
This sets the needed variables for the image_type_tezi class to create the tezi image. Related-to: ELB-5012 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb b/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
index 1e57428..26f08fc 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
@@ -24,3 +24,13 @@ UBOOT_INITIAL_ENV = "u-boot-initial-env"
COMPATIBLE_MACHINE = "(ti-soc)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+# preserve u-boot-initial-env even if u-boot-ti.inc tries to delete it
+do_compile:append () {
+ cp ${B}/u-boot-initial-env ${B}/u-boot-initial-env.preserved
+}
+
+do_deploy:append () {
+ install -D -m 644 ${B}/u-boot-initial-env.preserved ${DEPLOYDIR}/${UBOOT_INITIAL_ENV} || true
+ install -D -m 644 ${B}/u-boot-initial-env.preserved ${DEPLOYDIR}/ || true
+}