summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-02-16 18:26:39 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2023-02-16 18:46:58 +0100
commit1c74c7eb6e078b5bdf9b81f05a9e19652915a7b7 (patch)
treec5402b9e1ac1a7fad14ed888c082a778180fd737 /recipes-bsp
parent96ba7e7074d7b0f363095726b6a93acc71cbeffa (diff)
u-boot-toradex-ti-staging: fix u-boot-initial-env provider
Don't install u-boot-initial-env for the k3r5 spl build to prevent the following bitbake error: | ERROR: u-boot-toradex-ti-staging-1_2021.01+gitAUTOINC+f6f7a2258a-r0 do_deploy: The recipe u-boot-toradex-ti-staging is trying to install files into a shared area when those files already exist. Those files and their manifest location are: | .../deploy/images/verdin-am62/u-boot-initial-env | (matched in manifest-verdin_am62_k3r5-u-boot-toradex-ti-staging.deploy) Related-to: ELB-5012 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb b/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
index 26f08fc..39ee068 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-ti-staging_2021.01.bb
@@ -25,12 +25,14 @@ UBOOT_INITIAL_ENV = "u-boot-initial-env"
COMPATIBLE_MACHINE = "(ti-soc)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-# preserve u-boot-initial-env even if u-boot-ti.inc tries to delete it
+# preserve and deploy u-boot-initial-env if building for the Cortex-A53 core
+# even if u-boot-ti.inc do_deploy() tries to delete it.
do_compile:append () {
cp ${B}/u-boot-initial-env ${B}/u-boot-initial-env.preserved
}
+DEPLOY_INITIAL_ENV = "install -D -m 644 ${B}/u-boot-initial-env.preserved ${DEPLOYDIR}/${UBOOT_INITIAL_ENV} || true"
+DEPLOY_INITIAL_ENV:k3r5 = ":"
do_deploy:append () {
- install -D -m 644 ${B}/u-boot-initial-env.preserved ${DEPLOYDIR}/${UBOOT_INITIAL_ENV} || true
- install -D -m 644 ${B}/u-boot-initial-env.preserved ${DEPLOYDIR}/ || true
+ ${DEPLOY_INITIAL_ENV}
}