summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/files/full-hd.patch203
-rw-r--r--recipes-kernel/linux/linux-toradex.inc110
-rw-r--r--recipes-kernel/linux/linux-toradex_git.bb69
-rw-r--r--recipes-kernel/perf/perf.bbappend2
4 files changed, 0 insertions, 384 deletions
diff --git a/recipes-kernel/linux/files/full-hd.patch b/recipes-kernel/linux/files/full-hd.patch
deleted file mode 100644
index 41eab7d..0000000
--- a/recipes-kernel/linux/files/full-hd.patch
+++ /dev/null
@@ -1,203 +0,0 @@
-diff --git a/arch/arm/mach-tegra/board-apalis_t30-panel.c b/arch/arm/mach-tegra/board-apalis_t30-panel.c
-index f8f0672..5d4af1f 100644
---- a/arch/arm/mach-tegra/board-apalis_t30-panel.c
-+++ b/arch/arm/mach-tegra/board-apalis_t30-panel.c
-@@ -260,6 +260,7 @@ static struct tegra_dc_mode apalis_t30_panel_modes[] = {
- .v_front_porch = 10, /* lower_margin */
- },
- #else /* TEGRA_FB_VGA */
-+#if 0
- {
- /* 800x480@60 (e.g. EDT ET070080DH6) */
- .pclk = 32460000,
-@@ -410,6 +411,7 @@ static struct tegra_dc_mode apalis_t30_panel_modes[] = {
- .v_front_porch = 1,
- //high active vertical sync polarity
- },
-+#endif
- {
- /* LG LP156WF1 15.6 inch full HD dual channel LVDS panel */
- .pclk = 138500000,
-@@ -503,8 +505,8 @@ static struct tegra_fb_data apalis_t30_fb_data = {
- .xres = 640,
- .yres = 480,
- #else /* TEGRA_FB_VGA */
-- .xres = 800,
-- .yres = 480,
-+ .xres = 1920,
-+ .yres = 1080,
- #endif /* TEGRA_FB_VGA */
- .bits_per_pixel = 16,
- .flags = TEGRA_FB_FLIP_ON_PROBE,
-@@ -512,8 +514,8 @@ static struct tegra_fb_data apalis_t30_fb_data = {
-
- static struct tegra_fb_data apalis_t30_hdmi_fb_data = {
- .win = 0,
-- .xres = 640,
-- .yres = 480,
-+ .xres = 1920,
-+ .yres = 1080,
- .bits_per_pixel = 16,
- .flags = TEGRA_FB_FLIP_ON_PROBE,
- };
-diff --git a/arch/arm/mach-tegra/board-apalis_t30.h b/arch/arm/mach-tegra/board-apalis_t30.h
-index 38a86f6..e12ee96 100644
---- a/arch/arm/mach-tegra/board-apalis_t30.h
-+++ b/arch/arm/mach-tegra/board-apalis_t30.h
-@@ -125,7 +125,7 @@
- #define TDIODE_OFFSET (10000) /* in millicelsius */
-
- /* Run framebuffer in VGA mode */
--#define TEGRA_FB_VGA
-+//#define TEGRA_FB_VGA
-
- int apalis_t30_regulator_init(void);
- int apalis_t30_suspend_init(void);
-diff --git a/arch/arm/mach-tegra/board-colibri_t20-panel.c b/arch/arm/mach-tegra/board-colibri_t20-panel.c
-index 6d7ec83..f393b3b 100644
---- a/arch/arm/mach-tegra/board-colibri_t20-panel.c
-+++ b/arch/arm/mach-tegra/board-colibri_t20-panel.c
-@@ -224,6 +224,7 @@ static struct tegra_dc_mode colibri_t20_panel_modes[] = {
- .v_front_porch = 10, /* lower_margin */
- },
- #else /* TEGRA_FB_VGA */
-+#if 0
- #ifndef CONFIG_ANDROID
- {
- /* 800x480@60 (e.g. EDT ET070080DH6) */
-@@ -355,6 +356,7 @@ static struct tegra_dc_mode colibri_t20_panel_modes[] = {
- .v_front_porch = 1,
- //high active vertical sync polarity
- },
-+#endif
- {
- /* 1920x1080p 59.94/60hz EIA/CEA-861-B Format 16 */
- .pclk = 144000000,
-@@ -439,8 +441,8 @@ static struct tegra_fb_data colibri_t20_fb_data = {
- .yres = 480,
- #else /* TEGRA_FB_VGA */
- #ifndef CONFIG_ANDROID
-- .xres = 800,
-- .yres = 480,
-+ .xres = 1920,
-+ .yres = 1080,
- #else /* CONFIG_ANDROID */
- .xres = 1280,
- .yres = 720,
-@@ -452,8 +454,8 @@ static struct tegra_fb_data colibri_t20_fb_data = {
-
- static struct tegra_fb_data colibri_t20_hdmi_fb_data = {
- .win = 0,
-- .xres = 640,
-- .yres = 480,
-+ .xres = 1920,
-+ .yres = 1080,
- .bits_per_pixel = 16,
- .flags = TEGRA_FB_FLIP_ON_PROBE,
- };
-@@ -461,15 +463,15 @@ static struct tegra_fb_data colibri_t20_hdmi_fb_data = {
- static struct tegra_dc_out_pin colibri_t20_dc_out_pins[] = {
- {
- .name = TEGRA_DC_OUT_PIN_H_SYNC,
-- .pol = TEGRA_DC_OUT_PIN_POL_LOW,
-+ .pol = TEGRA_DC_OUT_PIN_POL_HIGH,
- },
- {
- .name = TEGRA_DC_OUT_PIN_V_SYNC,
-- .pol = TEGRA_DC_OUT_PIN_POL_LOW,
-+ .pol = TEGRA_DC_OUT_PIN_POL_HIGH,
- },
- {
- .name = TEGRA_DC_OUT_PIN_PIXEL_CLOCK,
-- .pol = TEGRA_DC_OUT_PIN_POL_LOW,
-+ .pol = TEGRA_DC_OUT_PIN_POL_HIGH,
- },
- };
-
-diff --git a/arch/arm/mach-tegra/board-colibri_t20.h b/arch/arm/mach-tegra/board-colibri_t20.h
-index b6b5e6a..8e82626 100644
---- a/arch/arm/mach-tegra/board-colibri_t20.h
-+++ b/arch/arm/mach-tegra/board-colibri_t20.h
-@@ -41,7 +41,7 @@
-
- /* Run framebuffer in VGA mode */
- #ifndef CONFIG_ANDROID
--#define TEGRA_FB_VGA
-+//#define TEGRA_FB_VGA
- #endif
-
- int colibri_t20_emc_init(void);
-diff --git a/arch/arm/mach-tegra/board-colibri_t30-panel.c b/arch/arm/mach-tegra/board-colibri_t30-panel.c
-index ee74874..c08241e 100644
---- a/arch/arm/mach-tegra/board-colibri_t30-panel.c
-+++ b/arch/arm/mach-tegra/board-colibri_t30-panel.c
-@@ -263,6 +263,7 @@ static struct tegra_dc_mode colibri_t30_panel_modes[] = {
- .v_front_porch = 10, /* lower_margin */
- },
- #else /* TEGRA_FB_VGA */
-+#if 0
- {
- /* 800x480@60 (e.g. EDT ET070080DH6) */
- .pclk = 32460000,
-@@ -400,6 +401,7 @@ static struct tegra_dc_mode colibri_t30_panel_modes[] = {
- .v_front_porch = 1,
- //high active vertical sync polarity
- },
-+#endif
- {
- /* 1920x1080p 59.94/60hz EIA/CEA-861-B Format 16 */
- .pclk = 148500000,
-@@ -480,8 +482,8 @@ static struct tegra_fb_data colibri_t30_fb_data = {
- .xres = 640,
- .yres = 480,
- #else /* TEGRA_FB_VGA */
-- .xres = 800,
-- .yres = 480,
-+ .xres = 1920,
-+ .yres = 1080,
- #endif /* TEGRA_FB_VGA */
- .bits_per_pixel = 16,
- .flags = TEGRA_FB_FLIP_ON_PROBE,
-@@ -489,8 +491,8 @@ static struct tegra_fb_data colibri_t30_fb_data = {
-
- static struct tegra_fb_data colibri_t30_hdmi_fb_data = {
- .win = 0,
-- .xres = 640,
-- .yres = 480,
-+ .xres = 1920,
-+ .yres = 1080,
- .bits_per_pixel = 16,
- .flags = TEGRA_FB_FLIP_ON_PROBE,
- };
-@@ -498,15 +500,15 @@ static struct tegra_fb_data colibri_t30_hdmi_fb_data = {
- static struct tegra_dc_out_pin colibri_t30_dc_out_pins[] = {
- {
- .name = TEGRA_DC_OUT_PIN_H_SYNC,
-- .pol = TEGRA_DC_OUT_PIN_POL_LOW,
-+ .pol = TEGRA_DC_OUT_PIN_POL_HIGH,
- },
- {
- .name = TEGRA_DC_OUT_PIN_V_SYNC,
-- .pol = TEGRA_DC_OUT_PIN_POL_LOW,
-+ .pol = TEGRA_DC_OUT_PIN_POL_HIGH,
- },
- {
- .name = TEGRA_DC_OUT_PIN_PIXEL_CLOCK,
-- .pol = TEGRA_DC_OUT_PIN_POL_LOW,
-+ .pol = TEGRA_DC_OUT_PIN_POL_HIGH,
- },
- };
-
-diff --git a/arch/arm/mach-tegra/board-colibri_t30.h b/arch/arm/mach-tegra/board-colibri_t30.h
-index 745d2a4..a243175 100644
---- a/arch/arm/mach-tegra/board-colibri_t30.h
-+++ b/arch/arm/mach-tegra/board-colibri_t30.h
-@@ -68,7 +68,7 @@
- #define TDIODE_OFFSET (10000) /* in millicelsius */
-
- /* Run framebuffer in VGA mode */
--#define TEGRA_FB_VGA
-+//#define TEGRA_FB_VGA
-
- int colibri_t30_regulator_init(void);
- int colibri_t30_suspend_init(void);
diff --git a/recipes-kernel/linux/linux-toradex.inc b/recipes-kernel/linux/linux-toradex.inc
deleted file mode 100644
index be5249e..0000000
--- a/recipes-kernel/linux/linux-toradex.inc
+++ /dev/null
@@ -1,110 +0,0 @@
-SUMMARY = "Linux Kernel for Toradex Tegra based modules"
-SECTION = "kernel"
-LICENSE = "GPLv2"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-
-inherit kernel siteinfo
-
-# Try to build & install perf
-#require recipes-kernel/linux/linux-tools.inc
-
-RPSRC = "http://www.rpsys.net/openzaurus/patches/archive"
-
-# Enable OABI compat for people stuck with obsolete userspace
-# ARM_KEEP_OABI ?= "1"
-
-# Quirk for udev greater or equal 141
-UDEV_GE_141 ?= "0"
-
-# Kernel bootlogo is distro-specific (default is OE logo).
-# Logo resolution (qvga, vga, ...) is machine-specific.
-LOGO_SIZE ?= "."
-
-# Support for binary device tree generation
-
-FILES_${KERNEL_PACKAGE_NAME}-devicetree = "/boot/devicetree*"
-
-#KERNEL_DEVICETREE to be specified from machine configuration
-
-KERNEL_DEVICETREE_FLAGS = "-R 8 -S 0x3000"
-
-CORTEXA8FIXUP ?= "yes"
-
-python __anonymous () {
-
- import bb
-
- devicetree = d.getVar('KERNEL_DEVICETREE', True) or ''
- if devicetree:
- depends = d.getVar("DEPENDS", True)
- d.setVar("DEPENDS", "%s dtc-native" % depends)
- packages = d.getVar("PACKAGES", True)
- d.setVar("PACKAGES", "%s kernel-devicetree" % packages)
-}
-
-do_configure_append() {
- if test -e scripts/Makefile.fwinst ; then
- sed -i -e "s:-m0644:-m 0644:g" scripts/Makefile.fwinst
- fi
-}
-
-# bitbake.conf only prepends PARALLEL make in tasks called do_compile, which isn't the case for compile_modules
-# So explicitly enable it for that in here
-EXTRA_OEMAKE = "${PARALLEL_MAKE} "
-
-do_uboot_mkimage_prepend() {
- mkdir arch/${ARCH}/boot/ || true
-}
-
-do_install_append() {
- oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}/src/linux-${KERNEL_VERSION} ARCH=$ARCH
-}
-
-PACKAGES =+ "kernel-headers"
-FILES_kernel-headers = "${exec_prefix}/src/linux*"
-
-do_devicetree_image() {
- if test -n "${KERNEL_DEVICETREE}" ; then
- dtc -I dts -O dtb ${KERNEL_DEVICETREE_FLAGS} -o devicetree ${KERNEL_DEVICETREE}
- install -d ${D}/boot
- install -m 0644 devicetree ${D}/boot/devicetree-${KERNEL_VERSION}
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0644 devicetree ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.dtb
- package_stagefile_shell ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.dtb
- cd ${DEPLOY_DIR_IMAGE}
- rm -f ${KERNEL_IMAGE_SYMLINK_NAME}.dtb
- ln -sf ${KERNEL_IMAGE_BASE_NAME}.dtb ${KERNEL_IMAGE_SYMLINK_NAME}.dtb
- package_stagefile_shell ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_SYMLINK_NAME}.dtb
- fi
-}
-
-do_devicetree_image_tegra124() {
-}
-
-addtask devicetree_image after do_install before do_package do_deploy
-
-pkg_postinst_kernel-devicetree () {
- cd /${KERNEL_IMAGEDEST}; update-alternatives --install /${KERNEL_IMAGEDEST}/devicetree devicetree devicetree-${KERNEL_VERSION} ${KERNEL_PRIORITY} || true
-}
-
-pkg_postrm_kernel-devicetree () {
- cd /${KERNEL_IMAGEDEST}; update-alternatives --remove devicetree devicetree-${KERNEL_VERSION} || true
-}
-
-# Automatically depend on lzop-native if CONFIG_KERNEL_LZO is enabled
-python () {
- try:
- defconfig = bb.fetch2.localpath('file://defconfig', d)
- except bb.fetch2.FetchError:
- return
-
- try:
- configfile = open(defconfig)
- except IOError:
- return
-
- if 'CONFIG_KERNEL_LZO=y\n' in configfile.readlines():
- depends = d.getVar('DEPENDS', False)
- d.setVar('DEPENDS', depends + ' lzop-native')
-}
diff --git a/recipes-kernel/linux/linux-toradex_git.bb b/recipes-kernel/linux/linux-toradex_git.bb
deleted file mode 100644
index fb54a50..0000000
--- a/recipes-kernel/linux/linux-toradex_git.bb
+++ /dev/null
@@ -1,69 +0,0 @@
-inherit kernel
-require recipes-kernel/linux/linux-toradex.inc
-include conf/tdx_version.conf
-
-LINUX_VERSION ?= "3.1.10"
-
-LOCALVERSION = "-${PR}"
-PR = "${TDX_VER_ITEM}"
-
-SRCREV = "841700f8a2eaeda184b0fcdd14711f6b2c62990c"
-SRCREV_use-head-next = "${AUTOREV}"
-
-PV = "${LINUX_VERSION}+gitr${SRCPV}"
-S = "${WORKDIR}/git"
-SRCBRANCH = "tegra"
-SRCBRANCH_use-head-next = "tegra-next"
-SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=${SRCBRANCH}"
-
-COMPATIBLE_MACHINE = "(apalis-t30|colibri-pxa|colibri-t20|colibri-t30)"
-
-# One possibiltiy for changes to the defconfig:
-config_script () {
-# #example change to the .config
-# #sets CONFIG_TEGRA_CAMERA unconditionally to 'y'
-# sed -i -e /CONFIG_TEGRA_CAMERA/d ${B}/.config
-# echo "CONFIG_TEGRA_CAMERA=y" >> ${B}/.config
- echo "dummy" > /dev/null
-}
-
-do_configure_prepend () {
- #use the defconfig provided in the kernel source tree
- #assume its called ${MACHINE}_defconfig, but with '_' instead of '-'
- DEFCONFIG="`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`"
-
- cd ${S}
- export KBUILD_OUTPUT=${B}
- oe_runmake $DEFCONFIG
-
- #maybe change some configuration
- config_script
-
- #Add Toradex BSP Version as LOCALVERSION
- sed -i -e /CONFIG_LOCALVERSION/d ${B}/.config
- echo "CONFIG_LOCALVERSION=\"${LOCALVERSION}\"" >> ${B}/.config
-
- #Add GIT revision to the local version
- head=`git --git-dir=${S}/.git rev-parse --verify --short HEAD 2> /dev/null`
- printf "%s%s" +g $head > ${S}/.scmversion
-
- cd - > /dev/null
-}
-
-do_uboot_mkimage_prepend () {
- cd ${B}
-}
-
-# glibc 2.24 set the oldest kernel to 3.2.0, however the downstream L4T 3.1.10
-# kernel provides all needed interfaces, so override the check_oldest_kernel to
-# disable the warning
-python check_oldest_kernel() {
- oldest_kernel = d.getVar('OLDEST_KERNEL', True)
- kernel_version = "3.2.0"
- tclibc = d.getVar('TCLIBC', True)
- if tclibc == 'glibc':
- kernel_version = kernel_version.split('-', 1)[0]
- if oldest_kernel and kernel_version:
- if bb.utils.vercmp_string(kernel_version, oldest_kernel) < 0:
- bb.warn('%s: OLDEST_KERNEL is "%s" but the version of the kernel you are building is "%s" - therefore %s as built may not be compatible with this kernel. Either set OLDEST_KERNEL to an older version, or build a newer kernel.' %(d.getVar('PN', True), oldest_kernel, kernel_version, tclibc))
-}
diff --git a/recipes-kernel/perf/perf.bbappend b/recipes-kernel/perf/perf.bbappend
index fea9271..dc60ab3 100644
--- a/recipes-kernel/perf/perf.bbappend
+++ b/recipes-kernel/perf/perf.bbappend
@@ -9,5 +9,3 @@ PERF_SRC_LEGACY_TEGRAS = "Makefile \
tools \
"
PERF_SRC_apalis-tk1 = "${PERF_SRC_LEGACY_TEGRAS}"
-PERF_SRC_apalis-t30 = "${PERF_SRC_LEGACY_TEGRAS}"
-PERF_SRC_colibri-t30 = "${PERF_SRC_LEGACY_TEGRAS}"