summaryrefslogtreecommitdiff
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-09-19 23:41:39 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 18:53:16 +0100
commit78f06aa513802054ccabe10fca0cdbe2a5f6981d (patch)
tree2cf9305884008a3d9951291c1a7b67b28f999562 /recipes-multimedia
parent2b35fa3b8f4777b1a026b7484a7cfd02d7ff00f3 (diff)
libgstomx-0.10: fix strncpy warning
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/libgstomx-0.10/files/0001-gstomx_util-fix-strncpy-warning.patch28
-rw-r--r--recipes-multimedia/libgstomx-0.10/libgstomx-0.10_21.7.0.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-multimedia/libgstomx-0.10/files/0001-gstomx_util-fix-strncpy-warning.patch b/recipes-multimedia/libgstomx-0.10/files/0001-gstomx_util-fix-strncpy-warning.patch
new file mode 100644
index 0000000..97bb2f3
--- /dev/null
+++ b/recipes-multimedia/libgstomx-0.10/files/0001-gstomx_util-fix-strncpy-warning.patch
@@ -0,0 +1,28 @@
+From 19fa5402774e2dea5d9400395cfd88a60db33afe Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Wed, 19 Sep 2018 21:11:15 +0000
+Subject: [PATCH] gstomx_util: fix strncpy warning
+
+| ./../gstomx_src/gst-openmax/omx/gstomx_util.c:329:7: error: 'strncpy' specified bound 128 equals destination size [-Werror=stringop-truncation]
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ omx/gstomx_util.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/omx/gstomx_util.c b/omx/gstomx_util.c
+index e74521a..352d9f7 100644
+--- a/omx/gstomx_util.c
++++ b/omx/gstomx_util.c
+@@ -327,7 +327,7 @@ g_omx_core_init (GOmxCore * core)
+ G_OMX_INIT_PARAM (param);
+
+ strncpy ((char *) param.cRole, core->component_role,
+- OMX_MAX_STRINGNAME_SIZE);
++ OMX_MAX_STRINGNAME_SIZE - 1);
+
+ OMX_SetParameter (core->omx_handle, OMX_IndexParamStandardComponentRole,
+ &param);
+--
+2.13.6
+
diff --git a/recipes-multimedia/libgstomx-0.10/libgstomx-0.10_21.7.0.bb b/recipes-multimedia/libgstomx-0.10/libgstomx-0.10_21.7.0.bb
index 897c01b..d73f5cc 100644
--- a/recipes-multimedia/libgstomx-0.10/libgstomx-0.10_21.7.0.bb
+++ b/recipes-multimedia/libgstomx-0.10/libgstomx-0.10_21.7.0.bb
@@ -7,6 +7,7 @@ SRC_URI = " \
https://developer.download.nvidia.com/embedded/L4T/r21_Release_v7.0/r21.7.0-sources.tbz2 \
file://0001-fix-gstomx-compilation-issues.patch \
file://0001-configure-don-t-use-gst-photography-even-if-it-is-in.patch \
+ file://0001-gstomx_util-fix-strncpy-warning.patch \
"
SRC_URI[md5sum] = "620d0979ffbbc8cbe8cb36faacee386b"