summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-23 20:35:21 -0700
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-03-14 14:26:28 +0100
commitb665ee26fc84a94e0e68c5c1a574e2defd736dde (patch)
treefe61e581dac62b0a6293b433eee29966e3244f13 /recipes-graphics
parentf3363da22157e2a33365087c4a40a9a2fcfada38 (diff)
xserver-xorg: Fix build with GCC 5
Backport a patch from fedora details are in patch header Change-Id: I6b8dfaae3b751071bf8b0d88b15a4f95c19877f6 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/0001-sdksyms.sh-Make-sdksyms.sh-work-with-gcc5.patch50
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_1.14.7.bb4
2 files changed, 53 insertions, 1 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/0001-sdksyms.sh-Make-sdksyms.sh-work-with-gcc5.patch b/recipes-graphics/xorg-xserver/xserver-xorg/0001-sdksyms.sh-Make-sdksyms.sh-work-with-gcc5.patch
new file mode 100644
index 0000000..215c044
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/0001-sdksyms.sh-Make-sdksyms.sh-work-with-gcc5.patch
@@ -0,0 +1,50 @@
+Upstream-Status: Pending
+
+From 612eb45a2e7a0b35cc3790870e6d0cc42eb50c74 Mon Sep 17 00:00:00 2001
+From: Hans de Goede <hdegoede@redhat.com>
+Date: Wed, 11 Feb 2015 16:26:40 +0100
+Subject: [PATCH] sdksyms.sh: Make sdksyms.sh work with gcc5.
+
+gcc5's cpp inserts patterns like this:
+
+extern
+ __attribute__((visibility("default")))
+ int WaitForSomething(int *
+ );
+
+This patch make sdksyms.sh work with this. Note my awk skills are weak, so
+there likely is a better way to deal with this.
+
+Signed-off-by: Hans de Goede <hdegoede@redhat.com>
+---
+ hw/xfree86/sdksyms.sh | 17 +++++++++++++++++
+ 1 file changed, 17 insertions(+)
+
+Index: xorg-server-1.16.3/hw/xfree86/sdksyms.sh
+===================================================================
+--- xorg-server-1.16.3.orig/hw/xfree86/sdksyms.sh
++++ xorg-server-1.16.3/hw/xfree86/sdksyms.sh
+@@ -353,6 +353,23 @@ BEGIN {
+ if (sdk) {
+ n = 3;
+
++ # detect the following gcc5 cpp pattern and skip it:
++ # extern
++ # # 320 "../../include/os.h" 3 4
++ # __attribute__((visibility("default")))
++ # # 320 "../../include/os.h"
++ # Note in this case the "extern " or "extern void " always has
++ # a trailing space
++ if ($0 ~ "^extern.* $") {
++ getline;
++ getline;
++ getline;
++ getline;
++ n = 1;
++ while ($n == " ")
++ n++;
++ }
++
+ # skip attribute, if any
+ while ($n ~ /^(__attribute__|__global)/ ||
+ # skip modifiers, if any
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.14.7.bb b/recipes-graphics/xorg-xserver/xserver-xorg_1.14.7.bb
index 2b2d13a..1050039 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg_1.14.7.bb
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.14.7.bb
@@ -10,7 +10,9 @@ SRC_URI += "file://crosscompile.patch \
file://mips64-compiler.patch \
file://aarch64.patch \
file://xorg-CVE-2013-6424.patch \
- "
+ file://0001-sdksyms.sh-Make-sdksyms.sh-work-with-gcc5.patch \
+"
+
SRC_URI[md5sum] = "0c285a813a6c3291c88d5a2b710aecb1"
SRC_URI[sha256sum] = "fcf66fa6ad86227613d2d3e8ae13ded297e2a1e947e9060a083eaf80d323451f"