summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-02-18 09:37:10 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 19:03:44 +0100
commit5036201925da2f4f4d48994d6c20513f683ea0ef (patch)
tree90bad5c2bb6fb6c9c663b2e1164b727704c2cca7 /recipes-graphics
parent90dd09c4014acc74791151f2b13281efae6aacd7 (diff)
tk1: drop meta-jetson-tk1
All of meta-jetson-tk1 has been moved into meta-toradex-tegra as updates were needed. Drop meta-jetson-tk1. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch41
-rwxr-xr-xrecipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch25
-rwxr-xr-xrecipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb43
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend26
4 files changed, 135 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch b/recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch
new file mode 100644
index 0000000..87a3112
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch
@@ -0,0 +1,41 @@
+From ee80095e03efcb6ff62983939c3f7c49c291f12e Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Wed, 19 Sep 2018 20:37:47 +0000
+Subject: [PATCH] sysmacros.h: follow changed include files
+
+minor/major is no longer provided by sys/types.h.
+explicitely include sysmacros.h where needed.
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ hw/xfree86/common/xf86Xinput.c | 1 +
+ hw/xfree86/os-support/linux/lnx_init.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/hw/xfree86/common/xf86Xinput.c b/hw/xfree86/common/xf86Xinput.c
+index 1fb5b16..4fc5a65 100644
+--- a/hw/xfree86/common/xf86Xinput.c
++++ b/hw/xfree86/common/xf86Xinput.c
+@@ -82,6 +82,7 @@
+ #include <stdarg.h>
+ #include <stdint.h> /* for int64_t */
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #ifdef HAVE_SYS_MKDEV_H
+diff --git a/hw/xfree86/os-support/linux/lnx_init.c b/hw/xfree86/os-support/linux/lnx_init.c
+index 4acaf33..ceae0f1 100644
+--- a/hw/xfree86/os-support/linux/lnx_init.c
++++ b/hw/xfree86/os-support/linux/lnx_init.c
+@@ -37,6 +37,7 @@
+ #include "xf86_OSlib.h"
+
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+
+ #ifndef K_OFF
+ #define K_OFF 0x4
+--
+2.13.6
+
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch b/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch
new file mode 100755
index 0000000..ec0eea6
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch
@@ -0,0 +1,25 @@
+This is the revised version of files/macro_tweak.patch for
+xorg-server 1.8.99.904 and newer.
+
+Upstream-Status: Pending
+
+Signed-off-by: Yu Ke <ke.yu@intel.com>
+
+diff --git a/xorg-server.m4 b/xorg-server.m4
+index bdecf62..040fdb8 100644
+--- a/xorg-server.m4
++++ b/xorg-server.m4
+@@ -28,10 +28,12 @@ dnl
+ # Checks for the $1 define in xorg-server.h (from the sdk). If it
+ # is defined, then add $1 to $REQUIRED_MODULES.
+
++m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR)
++
+ AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
+ AC_REQUIRE([PKG_PROG_PKG_CONFIG])
+ SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$CFLAGS -I`$PKG_CONFIG --variable=sdkdir xorg-server`"
++ CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=sdkdir xorg-server`"
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include "xorg-server.h"
+ #if !defined $1
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb b/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
new file mode 100755
index 0000000..06632b6
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
@@ -0,0 +1,43 @@
+require recipes-graphics/xorg-xserver/xserver-xorg.inc
+
+SRC_URI[md5sum] = "1509a9daae713895e7f5bcba8bcc05b2"
+SRC_URI[sha256sum] = "0c4b45c116a812a996eb432d8508cf26c2ec8c3916ff2a50781796882f8d6457"
+
+SRC_URI += "file://0001-sysmacros.h-follow-changed-include-files.patch"
+
+# These extensions are now integrated into the server, so declare the migration
+# path for in-place upgrades.
+
+RREPLACES_${PN} = "${PN}-extension-dri \
+ ${PN}-extension-dri2 \
+ ${PN}-extension-record \
+ ${PN}-extension-extmod \
+ ${PN}-extension-dbe \
+ "
+RPROVIDES_${PN} = "${PN}-extension-dri \
+ ${PN}-extension-dri2 \
+ ${PN}-extension-record \
+ ${PN}-extension-extmod \
+ ${PN}-extension-dbe \
+ "
+RCONFLICTS_${PN} = "${PN}-extension-dri \
+ ${PN}-extension-dri2 \
+ ${PN}-extension-record \
+ ${PN}-extension-extmod \
+ ${PN}-extension-dbe \
+ "
+# provided by xf86-input-evdev_2.10.0
+do_install_append () {
+ rm -f ${D}/usr/share/X11/xorg.conf.d/10-evdev.conf
+}
+
+# override setting from xserver-xorg.inc which only applies to version 1.18.
+#| checking for PIXMAN... yes
+#| checking for SYSTEMD_DAEMON... no
+#| configure: error: systemd support requested but no library has been found
+#| ERROR: Function failed: do_configure (log file is located at /build/krm/oe-core_V2.6.2/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/xserver-xorg/2_1.17.2-r0/temp/log.do_configure.2158)
+
+PACKAGECONFIG ?= "dri2 udev ${XORG_CRYPTO} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri glx', '', d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "xwayland", "", d)} \
+"
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend
new file mode 100644
index 0000000..9a577a8
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bbappend
@@ -0,0 +1,26 @@
+# always latest and greatest.
+PE_tegra124 = "99"
+
+PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"
+
+COMPATIBLE_MACHINE = "(apalis-tk1|jetson-tk1|jetson-tk1-l4t)"
+
+DEPENDS_append = " libxfont"
+
+# provided by xf86-input-evdev_2.10.0
+do_install_append () {
+ rm -f ${D}/usr/share/X11/xorg.conf.d/10-evdev.conf
+}
+
+#| checking for PIXMAN... yes
+#| checking for SYSTEMD_DAEMON... no
+#| configure: error: systemd support requested but no library has been found
+#| ERROR: Function failed: do_configure (log file is located at .../xserver-xorg/2_1.17.2-r0/temp/log.do_configure.2158)
+
+PACKAGECONFIG ?= "dri2 udev ${XORG_CRYPTO} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri glx', '', d)} \
+ ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "xwayland", "", d)} \
+"
+
+# The NVidia driver needs this enabled.
+PACKAGECONFIG_append = " xinerama "