summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2021-06-02 18:57:45 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-06-04 14:12:13 +0200
commitc747f7c07e4cd7f5e8e8cf8e5ff8ab5bcb2facaa (patch)
treee87752b2aad4ebcee939b7e423259e2812fec291 /recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb
parent8ffd1b7b955fe540167f410f24fe4f0ff77a128a (diff)
u-boot-toradex-tk1: complete update to 2020.07
While we did rename the branch we forgot to also rename this recipe. Fix this. Fixes commit a21f73d1e08e ("u-boot-toradex: update to 2020.07") Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> (cherry picked from commit 1f19651ec747c4842dfd0dba25bc056322f2edac)
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb b/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb
new file mode 100644
index 0000000..ade3907
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb
@@ -0,0 +1,27 @@
+require u-boot-toradex-common-tk1.inc
+require recipes-bsp/u-boot/u-boot.inc
+
+B = "${WORKDIR}/build"
+
+DEPENDS += "bc-native dtc-native"
+DEPENDS_append_apalis-tk1 = " cbootimage-native"
+
+PROVIDES += "u-boot"
+
+COMPATIBLE_MACHINE = "(apalis-tk1)"
+
+SRC_URI_append_apalis-tk1 = " \
+ file://apalis-tk1.img.cfg \
+ file://fw_env.config \
+ file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
+"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_deploy_append_apalis-tk1() {
+ cd ${DEPLOYDIR}
+ cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
+ cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
+ rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
+}
+