summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-11-08 23:14:21 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-12-20 17:04:20 +0100
commitd90986dcafdd04db05f693836b991b31a16ea35a (patch)
tree8e6ba69db5f9a2a736cb05051616ef92bdca0375 /recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
parente0552c1372df66faa9f8080a1524ffdf2b84e07d (diff)
u-boot-fw-utils: follow the compile fixes for native/cross used in oe-core
The U-Boot Makefile has a unusual way of compiling the user space tools which results in the wrong toolchain (native vs. target) being used. Drop our downstream fix in favour of how openembedded-core does this now. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb15
1 files changed, 12 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index f0b8191..904415b 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -25,6 +25,7 @@ SRCREV_use-head-next = "${AUTOREV}"
SRCBRANCH_use-head-next = "2016.11-toradex-next"
SRC_URI = " \
git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
+ file://default-gcc.patch \
file://fw_env.config \
"
SRC_URI_append_tegra3 = " file://fw_unlock_mmc.sh"
@@ -37,9 +38,9 @@ S = "${WORKDIR}/git"
#actually this depend on the upstream U-Boot version and not on the machine
CC_remove = "-mfpu=neon"
-EXTRA_OEMAKE = 'CC="${CC}"'
-
-INSANE_SKIP_${PN} = "already-stripped ldflags"
+INSANE_SKIP_${PN} = "already-stripped"
+EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
+EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
inherit pkgconfig uboot-config
@@ -73,4 +74,12 @@ pkg_postinst_${PN}_colibri-t20 () {
grep u-boot-env /proc/mtd | awk '{print "/dev/" substr($1,0,4) " 0x00000000 0x00010000 0x" $3 " 1" >> "/etc/fw_env.config" }'
}
+do_install_class-cross () {
+ install -d ${D}${bindir_cross}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
+}
+
+SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"