summaryrefslogtreecommitdiff
path: root/recipes-bsp/tegrarcm
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-11-11 00:13:16 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-11-13 07:55:23 +0100
commit136eb6096cf64a8aa66af50e383c4916bd3c59ca (patch)
treec622886d8e2ed82c3e2599d7cffbe55937459fce /recipes-bsp/tegrarcm
parentdff31b1934bb5ea0bfb7e87591105c37d21d6f84 (diff)
cbootimage/imx-loader/mtd-utils/tegrarcm: fix 32-bit build of our bsp/devtools
Diffstat (limited to 'recipes-bsp/tegrarcm')
-rw-r--r--recipes-bsp/tegrarcm/tegrarcm.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-bsp/tegrarcm/tegrarcm.bb b/recipes-bsp/tegrarcm/tegrarcm.bb
index 0180a36..b4aedb6 100644
--- a/recipes-bsp/tegrarcm/tegrarcm.bb
+++ b/recipes-bsp/tegrarcm/tegrarcm.bb
@@ -15,6 +15,9 @@ PV = "1.6"
EXTRA_OEMAKE='PREFIX="${prefix}" LIBDIR="${libdir}"'
+#we want tegrarcm binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
+EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32'"
+
do_compile () {
oe_runmake CPPFLAGS=-I${includedir}/cryptopp || die "make failed"
}