summaryrefslogtreecommitdiff
path: root/recipes-bsp/lvds-ctrl
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-03-20 10:25:11 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2013-03-20 10:25:11 +0100
commitf3792465452112caee8e5da971def68882423f6e (patch)
tree9720a795c21b5a9016f3f2bbc1b97e9e5d36a04b /recipes-bsp/lvds-ctrl
parentcf2f12ccd2a956a5ed2207541447ea8c87b8d110 (diff)
lvds: autostart the dual lane script
Diffstat (limited to 'recipes-bsp/lvds-ctrl')
-rw-r--r--recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb b/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
index 826070f..3710c7a 100644
--- a/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
+++ b/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Scripts to enable the LVDS converter on Apalis-T30"
LICENSE = "Public Domain"
-PR = "r1"
+PR = "r2"
SRC_URI = " \
file://lvds-dual-channel.sh \
@@ -17,3 +17,12 @@ do_install () {
install -d ${D}/${bindir}
install -m 0755 ${WORKDIR}/*.sh ${D}/${bindir}
}
+
+pkg_postinst_${PN}() {
+ mkdir -p ${sysconfdir}/xdg/lxsession/LXDE
+ echo "${bindir}/lvds-dual-channel.sh" >> ${sysconfdir}/xdg/lxsession/LXDE/autostart
+}
+
+pkg_postremove_${PN}() {
+ sed -i /${bindir}/lvds-dual-channel.sh/d ${sysconfdir}/xdg/lxsession/LXDE/autostart || true
+}