summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2015-05-01 15:42:46 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2015-05-12 10:04:36 +0200
commitc1e90a1418e11a7763bf7a52f876db6c72c76fb0 (patch)
treedc8dc09dca8e163bd2d94d28aa7ab24ca612db86
parent2d0ffd84a82cd3d75a37af5a98fe2584448ea4cc (diff)
apalis/colibri_t20/t30: integrate latest stuff
-rw-r--r--conf/machine/colibri-t20.conf4
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb37
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb54
-rw-r--r--recipes-kernel/linux/linux-toradex_git.bb18
4 files changed, 34 insertions, 79 deletions
diff --git a/conf/machine/colibri-t20.conf b/conf/machine/colibri-t20.conf
index 6696554..3e866dc 100644
--- a/conf/machine/colibri-t20.conf
+++ b/conf/machine/colibri-t20.conf
@@ -7,11 +7,11 @@ require conf/machine/include/soc-family.inc
PREFERRED_PROVIDER_virtual/kernel = "linux-toradex"
-KERNEL_IMAGETYPE = "uImage"
+KERNEL_IMAGETYPE = "zImage"
PREFERRED_PROVIDER_u-boot = "u-boot-toradex"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex"
-UBOOT_MACHINE = "colibri_t20_config"
+UBOOT_MACHINE = "colibri_t20_defconfig"
UBOOT_ENTRYPOINT = "0x00008000"
PREFERRED_PROVIDER_virtual/xserver_tegra = "xserver-xorg"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index dce8fa1..c32e239 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -1,47 +1,32 @@
SUMMARY = "U-boot bootloader fw_printenv/setenv utils"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM_colibri-t20 = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
- file://README;beginline=1;endline=22;md5=5ba4218ac89af7846802d0348df3fb90"
-LIC_FILES_CHKSUM_tegra3 = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
+LIC_FILES_CHKSUM_tegra = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
SECTION = "bootloader"
PROVIDES = "u-boot-fw-utils"
DEPENDS = "mtd-utils"
-COMPATIBLE_MACHINE = "(colibri-t20|colibri-t30|apalis-t30)"
+COMPATIBLE_MACHINE = "(apalis-t30|colibri-t20|colibri-t30)"
+DEFAULT_PREFERENCE_apalis-t30 = "1"
DEFAULT_PREFERENCE_colibri-t20 = "1"
DEFAULT_PREFERENCE_colibri-t30 = "1"
-DEFAULT_PREFERENCE_apalis-t30 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
-SRC_URI_T20 = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-SRC_URI_T20 += "file://fw_env.config"
-SRC_URI_T30 = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=2014.10-toradex"
-SRC_URI_T30 += "file://fw_env.config"
-# This revision is based on upstream "v2011.06"
-SRCREV_T20 = "278ca22a59e3df4dd1e1494e8920a01c172118af"
-# This revision is based on upstream "v2014.10"
-SRCREV_T30 = "f7e57f71da1eecbf1ac28339868d15492c929925"
+SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=2015.04-toradex-next"
+SRC_URI += "file://fw_env.config"
+# This revision is based on upstream "v2015.04"
+SRCREV = "d536cdbdf8e8765a2d223b2c38c0fa2e8ff36f12"
+PV_apalis-t30 = "${PR}+gitr${SRCREV}"
PV_colibri-t20 = "${PR}+gitr${SRCREV}"
PV_colibri-t30 = "${PR}+gitr${SRCREV}"
-PV_apalis-t30 = "${PR}+gitr${SRCREV}"
-
-SRC_URI_colibri-t20 = "${SRC_URI_T20}"
-SRC_URI_colibri-t30 = "${SRC_URI_T30}"
-SRC_URI_apalis-t30 = "${SRC_URI_T30}"
-
-SRCREV_colibri-t20 = "${SRCREV_T20}"
-SRCREV_colibri-t30 = "${SRCREV_T30}"
-SRCREV_apalis-t30 = "${SRCREV_T30}"
S = "${WORKDIR}/git"
#actually this depend on the upstream U-Boot version and not on the machine
-CC_remove_tegra3 = "-mfpu=neon"
-EXTRA_OEMAKE_tegra3 = 'CC="${CC}"'
-EXTRA_OEMAKE_tegra2 = 'HOSTCC="${CC}" HOSTSTRIP="true"'
+CC_remove = "-mfpu=neon"
+EXTRA_OEMAKE = 'CC="${CC}"'
INSANE_SKIP_${PN} = "already-stripped"
@@ -64,7 +49,7 @@ pkg_postinst_${PN}_colibri-t20 () {
if [ "x$D" != "x" ]; then
exit 1
fi
- grep ENV /proc/mtd | awk '{print "/dev/" substr($1,0,4) " 0x00000000 0x00001000 0x" $3 " 1" >> "/etc/fw_env.config" }'
+ grep u-boot-env /proc/mtd | awk '{print "/dev/" substr($1,0,4) " 0x00000000 0x00001000 0x" $3 " 1" >> "/etc/fw_env.config" }'
}
pkg_postinst_${PN}_tegra3 () {
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index 4122463..d25788d 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -4,59 +4,29 @@ PROVIDES = "u-boot"
DEPENDS += "dtc-native"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM_colibri-t20 = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
- file://README;beginline=1;endline=22;md5=5ba4218ac89af7846802d0348df3fb90"
-LIC_FILES_CHKSUM_tegra3 = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
-COMPATIBLE_MACHINE = "(colibri-t20|colibri-t30|apalis-t30)"
+COMPATIBLE_MACHINE = "(apalis-t30|colibri-t20|colibri-t30)"
+DEFAULT_PREFERENCE_apalis-t30 = "1"
DEFAULT_PREFERENCE_colibri-t20 = "1"
DEFAULT_PREFERENCE_colibri-t30 = "1"
-DEFAULT_PREFERENCE_apalis-t30 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
-SRC_URI_T20 = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-SRC_URI_T30 = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=2014.10-toradex"
-# This revision is based on upstream "v2011.06"
-SRCREV_T20 = "278ca22a59e3df4dd1e1494e8920a01c172118af"
-# This revision is based on upstream "v2014.10"
-SRCREV_T30 = "f7e57f71da1eecbf1ac28339868d15492c929925"
-
-PV_colibri-t20 = "${PR}+gitr${SRCREV}"
-PV_colibri-t30 = "${PR}+gitr${SRCREV}"
-PV_apalis-t30 = "${PR}+gitr${SRCREV}"
+SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=2015.04-toradex-next"
+# This revision is based on upstream "v2015.04"
+SRCREV = "d536cdbdf8e8765a2d223b2c38c0fa2e8ff36f12"
-SRC_URI_colibri-t20 = "${SRC_URI_T20}"
-SRC_URI_colibri-t30 = "${SRC_URI_T30}"
-SRC_URI_apalis-t30 = "${SRC_URI_T30}"
-
-SRCREV_colibri-t20 = "${SRCREV_T20}"
-SRCREV_colibri-t30 = "${SRCREV_T30}"
-SRCREV_apalis-t30 = "${SRCREV_T30}"
+PV = "${PR}+gitr${SRCREV}"
# override the solution passed in from u-boot.inc as we want to set additional flags
-EXTRA_OEMAKE_colibri-t20 = "CROSS_COMPILE=${TARGET_PREFIX}"
-EXTRA_OEMAKE_colibri-t30 = "CROSS_COMPILE=${TARGET_PREFIX}"
-EXTRA_OEMAKE_apalis-t30 = "CROSS_COMPILE=${TARGET_PREFIX}"
-
-# apalis/colibri-t30: require u-boot-dtb-tegra.bin to be used
-UBOOT_IMAGE_tegra3 = "u-boot-dtb-tegra-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
-UBOOT_BINARY_tegra3 = "u-boot-dtb-tegra.${UBOOT_SUFFIX}"
-UBOOT_SYMLINK_tegra3 = "u-boot-dtb-tegra-${MACHINE}.${UBOOT_SUFFIX}"
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
-# colibri-t20: build additionally a u-boot binary which uses/stores its environment on an T20 external sd or mmc card
-SPL_BINARY_colibri-t20 = "u-boot-hsmmc.bin"
-SPL_IMAGE_colibri-t20 = "u-boot-hsmmc-${MACHINE}-${PV}-${PR}.bin"
-SPL_SYMLINK_colibri-t20 = "u-boot-hsmmc-${MACHINE}.bin"
-do_compile_append_colibri-t20() {
- # keep u-boot-nand
- mv u-boot.bin u-boot-nand.bin
- oe_runmake colibri_t20_sdboot_config
- oe_runmake ${UBOOT_MAKE_TARGET}
- mv u-boot.bin u-boot-hsmmc.bin
- mv u-boot-nand.bin u-boot.bin
-}
+# require u-boot-dtb-tegra.bin to be used
+UBOOT_IMAGE = "u-boot-dtb-tegra-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
+UBOOT_BINARY = "u-boot-dtb-tegra.${UBOOT_SUFFIX}"
+UBOOT_SYMLINK = "u-boot-dtb-tegra-${MACHINE}.${UBOOT_SUFFIX}"
#do_install_append() {
#}
diff --git a/recipes-kernel/linux/linux-toradex_git.bb b/recipes-kernel/linux/linux-toradex_git.bb
index af258ba..05198bf 100644
--- a/recipes-kernel/linux/linux-toradex_git.bb
+++ b/recipes-kernel/linux/linux-toradex_git.bb
@@ -3,21 +3,21 @@ require recipes-kernel/linux/linux-toradex.inc
LINUX_VERSION ?= "3.1.10"
-SRCREV_colibri-t20 = "e797e34a3f7cb82c4e5b249a525c9e857ac6eebd"
-PR_colibri-t20 = "V2.3"
-SRCREV_colibri-t30 = "e797e34a3f7cb82c4e5b249a525c9e857ac6eebd"
-PR_colibri-t30 = "V2.3"
-SRCREV_apalis-t30 = "e797e34a3f7cb82c4e5b249a525c9e857ac6eebd"
-PR_apalis-t30 = "V2.3"
+SRCREV_apalis-t30 = "834b98d0367931d6bec5a48fe87fddd9b877f688"
+PR_apalis-t30 = "V2.4"
SRCREV_colibri-pxa = "a699c4f23852bad780b8ad5273d5a3171cd461f9"
-PR_colibri-pxa = "V2.3a1"
+PR_colibri-pxa = "V2.4a1"
+SRCREV_colibri-t20 = "834b98d0367931d6bec5a48fe87fddd9b877f688"
+PR_colibri-t20 = "V2.4"
+SRCREV_colibri-t30 = "834b98d0367931d6bec5a48fe87fddd9b877f688"
+PR_colibri-t30 = "V2.4"
PV = "${LINUX_VERSION}+gitr${SRCREV}"
S = "${WORKDIR}/git"
-SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=tegra"
+SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=tegra-nand-next"
-COMPATIBLE_MACHINE = "(colibri-t20|colibri-t30|apalis-t30|colibri-pxa)"
+COMPATIBLE_MACHINE = "(apalis-t30|colibri-pxa|colibri-t20|colibri-t30)"
# One possibiltiy for changes to the defconfig:
config_script () {