summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/fs-init/fs-init.bb4
-rw-r--r--recipes-core/set-hostname/set-hostname_1.0.bb4
-rw-r--r--recipes-core/systemd/systemd-conf_%.bbappend2
-rw-r--r--recipes-core/systemd/systemd_%.bbappend2
-rw-r--r--recipes-core/udev/udev-extraconf_%.bbappend6
-rw-r--r--recipes-core/util-linux/util-linux_%.bbappend8
6 files changed, 13 insertions, 13 deletions
diff --git a/recipes-core/fs-init/fs-init.bb b/recipes-core/fs-init/fs-init.bb
index 023f347..bb9b1b8 100644
--- a/recipes-core/fs-init/fs-init.bb
+++ b/recipes-core/fs-init/fs-init.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Script to expand the rootfs to the full size of its partion, star
LICENSE = "PD"
PR = "r3"
-RRECOMMENDS_${PN} = "e2fsprogs-resize2fs"
+RRECOMMENDS:${PN} = "e2fsprogs-resize2fs"
SRC_URI = " \
file://resizefs.sh \
@@ -22,6 +22,6 @@ do_install () {
}
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "resizefs.service"
+SYSTEMD_SERVICE:${PN} = "resizefs.service"
inherit allarch systemd
diff --git a/recipes-core/set-hostname/set-hostname_1.0.bb b/recipes-core/set-hostname/set-hostname_1.0.bb
index 15fa66b..b39abdb 100644
--- a/recipes-core/set-hostname/set-hostname_1.0.bb
+++ b/recipes-core/set-hostname/set-hostname_1.0.bb
@@ -10,12 +10,12 @@ SRC_URI += " \
file://set-hostname.service \
"
-FILES_${PN} = " \
+FILES:${PN} = " \
${bindir} \
${systemd_system_unitdir} \
"
-SYSTEMD_SERVICE_${PN} = " \
+SYSTEMD_SERVICE:${PN} = " \
set-hostname.service \
"
diff --git a/recipes-core/systemd/systemd-conf_%.bbappend b/recipes-core/systemd/systemd-conf_%.bbappend
index 77ab59d..fccd438 100644
--- a/recipes-core/systemd/systemd-conf_%.bbappend
+++ b/recipes-core/systemd/systemd-conf_%.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/systemd-conf:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/systemd-conf:"
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index ea40849..2a022be 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -1,4 +1,4 @@
# This allows for udevd automounting with mounts accessible to all.
-do_configure_prepend () {
+do_configure:prepend () {
sed -i '/PrivateMounts=yes/d' ${S}/units/systemd-udevd.service.in
} \ No newline at end of file
diff --git a/recipes-core/udev/udev-extraconf_%.bbappend b/recipes-core/udev/udev-extraconf_%.bbappend
index 7b03d77..7820aa2 100644
--- a/recipes-core/udev/udev-extraconf_%.bbappend
+++ b/recipes-core/udev/udev-extraconf_%.bbappend
@@ -1,10 +1,10 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files/:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files/:"
-SRC_URI_append = " file://hotplug.rules \
+SRC_URI:append = " file://hotplug.rules \
file://hotplug.sh \
"
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}/udev/rules.d
install -m 0644 ${WORKDIR}/hotplug.rules ${D}${sysconfdir}/udev/rules.d/hotplug.rules
diff --git a/recipes-core/util-linux/util-linux_%.bbappend b/recipes-core/util-linux/util-linux_%.bbappend
index 341efcf..b922d21 100644
--- a/recipes-core/util-linux/util-linux_%.bbappend
+++ b/recipes-core/util-linux/util-linux_%.bbappend
@@ -1,13 +1,13 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append_ = " file://fstrim.service file://fstrim.timer"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+SRC_URI:append_ = " file://fstrim.service file://fstrim.timer"
inherit systemd
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "fstrim.service fstrim.timer"
+SYSTEMD_SERVICE:${PN} = "fstrim.service fstrim.timer"
SYSTEMD_AUTO_ENABLE = "disable"
-do_install_append() {
+do_install:append() {
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/fstrim.service ${D}${systemd_unitdir}/system/
install -m 0644 ${WORKDIR}/fstrim.timer ${D}${systemd_unitdir}/system/