summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/systemd/systemd-conf_%.bbappend2
-rw-r--r--recipes-core/systemd/systemd_%.bbappend4
-rw-r--r--recipes-core/udev/udev-extraconf_%.bbappend6
3 files changed, 6 insertions, 6 deletions
diff --git a/recipes-core/systemd/systemd-conf_%.bbappend b/recipes-core/systemd/systemd-conf_%.bbappend
index fccd438..34e18d6 100644
--- a/recipes-core/systemd/systemd-conf_%.bbappend
+++ b/recipes-core/systemd/systemd-conf_%.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/systemd-conf:"
+FILESEXTRAPATHS:prepend:tdx := "${THISDIR}/systemd-conf:"
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index 2a022be..5bd3016 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -1,4 +1,4 @@
# This allows for udevd automounting with mounts accessible to all.
-do_configure:prepend () {
+do_configure:prepend:tdx () {
sed -i '/PrivateMounts=yes/d' ${S}/units/systemd-udevd.service.in
-} \ No newline at end of file
+}
diff --git a/recipes-core/udev/udev-extraconf_%.bbappend b/recipes-core/udev/udev-extraconf_%.bbappend
index 7820aa2..0a380a8 100644
--- a/recipes-core/udev/udev-extraconf_%.bbappend
+++ b/recipes-core/udev/udev-extraconf_%.bbappend
@@ -1,10 +1,10 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/files/:"
-SRC_URI:append = " file://hotplug.rules \
- file://hotplug.sh \
+SRC_URI:append:tdx = " file://hotplug.rules \
+ file://hotplug.sh \
"
-do_install:append() {
+do_install:append:tdx () {
install -d ${D}${sysconfdir}/udev/rules.d
install -m 0644 ${WORKDIR}/hotplug.rules ${D}${sysconfdir}/udev/rules.d/hotplug.rules