summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/set-hostname/files/sethostname2
-rw-r--r--recipes-core/set-hostname/set-hostname_1.1.bb (renamed from recipes-core/set-hostname/set-hostname_1.0.bb)2
-rw-r--r--recipes-core/udev/files/aquila-am69/10-toradex-can0-ifname.link6
-rw-r--r--recipes-core/udev/files/aquila-am69/10-toradex-can1-ifname.link6
-rw-r--r--recipes-core/udev/files/aquila-am69/10-toradex-can10-ifname.link6
-rw-r--r--recipes-core/udev/files/aquila-am69/10-toradex-can13-ifname.link6
-rw-r--r--recipes-core/udev/files/aquila-am69/99-toradex.rules21
-rw-r--r--recipes-core/udev/udev-extraconf_%.bbappend1
8 files changed, 48 insertions, 2 deletions
diff --git a/recipes-core/set-hostname/files/sethostname b/recipes-core/set-hostname/files/sethostname
index 87e6320..aacb7ab 100644
--- a/recipes-core/set-hostname/files/sethostname
+++ b/recipes-core/set-hostname/files/sethostname
@@ -13,7 +13,7 @@ fi
hostname=@@MACHINE@@"-"${serial}
if [ -f /usr/bin/hostnamectl ]; then
- /usr/bin/hostnamectl set-hostname ${hostname}
+ /usr/bin/hostnamectl set-hostname @@HOSTNAMECTL_OPT@@ ${hostname}
else
hostname ${hostname}
fi
diff --git a/recipes-core/set-hostname/set-hostname_1.0.bb b/recipes-core/set-hostname/set-hostname_1.1.bb
index b39abdb..e9c3878 100644
--- a/recipes-core/set-hostname/set-hostname_1.0.bb
+++ b/recipes-core/set-hostname/set-hostname_1.1.bb
@@ -23,6 +23,8 @@ do_install () {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/sethostname ${D}${bindir}
sed -i "s/@@MACHINE@@/${MACHINE}/g" ${D}${bindir}/sethostname
+ sed -i "s/@@HOSTNAMECTL_OPT@@/${@bb.utils.contains('IMAGE_FEATURES','read-only-rootfs','--transient','',d)}/g" \
+ ${D}${bindir}/sethostname
if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/set-hostname.service ${D}${systemd_system_unitdir}
diff --git a/recipes-core/udev/files/aquila-am69/10-toradex-can0-ifname.link b/recipes-core/udev/files/aquila-am69/10-toradex-can0-ifname.link
new file mode 100644
index 0000000..7058581
--- /dev/null
+++ b/recipes-core/udev/files/aquila-am69/10-toradex-can0-ifname.link
@@ -0,0 +1,6 @@
+[Match]
+Property=ID_PATH=platform-40528000.can
+
+[Link]
+AlternativeNamesPolicy=
+AlternativeName=aquila-can2
diff --git a/recipes-core/udev/files/aquila-am69/10-toradex-can1-ifname.link b/recipes-core/udev/files/aquila-am69/10-toradex-can1-ifname.link
new file mode 100644
index 0000000..284ba25
--- /dev/null
+++ b/recipes-core/udev/files/aquila-am69/10-toradex-can1-ifname.link
@@ -0,0 +1,6 @@
+[Match]
+Property=ID_PATH=platform-40568000.can
+
+[Link]
+AlternativeNamesPolicy=
+AlternativeName=aquila-can4
diff --git a/recipes-core/udev/files/aquila-am69/10-toradex-can10-ifname.link b/recipes-core/udev/files/aquila-am69/10-toradex-can10-ifname.link
new file mode 100644
index 0000000..03d124f
--- /dev/null
+++ b/recipes-core/udev/files/aquila-am69/10-toradex-can10-ifname.link
@@ -0,0 +1,6 @@
+[Match]
+Property=ID_PATH=platform-27a1000.can
+
+[Link]
+AlternativeNamesPolicy=
+AlternativeName=aquila-can1
diff --git a/recipes-core/udev/files/aquila-am69/10-toradex-can13-ifname.link b/recipes-core/udev/files/aquila-am69/10-toradex-can13-ifname.link
new file mode 100644
index 0000000..12502d7
--- /dev/null
+++ b/recipes-core/udev/files/aquila-am69/10-toradex-can13-ifname.link
@@ -0,0 +1,6 @@
+[Match]
+Property=ID_PATH=platform-27d1000.can
+
+[Link]
+AlternativeNamesPolicy=
+AlternativeName=aquila-can3
diff --git a/recipes-core/udev/files/aquila-am69/99-toradex.rules b/recipes-core/udev/files/aquila-am69/99-toradex.rules
new file mode 100644
index 0000000..a40a5a2
--- /dev/null
+++ b/recipes-core/udev/files/aquila-am69/99-toradex.rules
@@ -0,0 +1,21 @@
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="40b00000.i2c", SYMLINK+="aquila-i2c1"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="40b10000.i2c", SYMLINK+="aquila-i2c2"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="2000000.i2c", SYMLINK+="aquila-i2c3"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="2010000.i2c", SYMLINK+="aquila-i2c4"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="2020000.i2c", SYMLINK+="aquila-i2c5"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="2050000.i2c", SYMLINK+="aquila-i2c6"
+ACTION=="add|change", KERNEL=="i2c-[0-9]*", KERNELS=="42120000.i2c", SYMLINK+="aquila-i2c-on-module"
+ACTION=="add|change", KERNEL=="ttyS[0-9]*", KERNELS=="2810000.serial", SYMLINK+="aquila-uart1"
+ACTION=="add|change", KERNEL=="ttyS[0-9]*", KERNELS=="42300000.serial", SYMLINK+="aquila-uart2"
+ACTION=="add|change", KERNEL=="ttyS[0-9]*", KERNELS=="2880000.serial", SYMLINK+="aquila-uart3"
+ACTION=="add|change", KERNEL=="ttyS[0-9]*", KERNELS=="2800000.serial", SYMLINK+="aquila-uart4"
+ACTION=="add|change", KERNELS=="watchdog", SYMLINK+="aquila-watchdog", SYMLINK+="aquila-watchdog-soc"
+ACTION=="add|change", SUBSYSTEM=="spidev", KERNELS=="2120000.*spi", SYMLINK+="aquila-spi1-cs%n"
+ACTION=="add|change", SUBSYSTEM=="spidev", KERNELS=="2100000.*spi", SYMLINK+="aquila-spi2-cs%n"
+KERNEL=="mmcblk[0-9]", ENV{DEVTYPE}=="disk", KERNELS=="4f80000.mmc", SYMLINK+="emmc"
+KERNEL=="mmcblk[0-9]boot[0-9]", ENV{DEVTYPE}=="disk", KERNELS=="4f80000.mmc", SYMLINK+="emmc-boot%n"
+KERNEL=="mmcblk[0-9]p[0-9]", ENV{DEVTYPE}=="partition", KERNELS=="4f80000.mmc", SYMLINK+="emmc-part%n"
+#TODO ADC
+#SUBSYSTEM=="iio", KERNELS=="iio:device0", RUN+="/etc/udev/scripts/toradex-adc.sh"
+ACTION=="add|change", KERNEL=="mmcblk[0-9]", KERNELS=="4fb0000.mmc", SYMLINK+="aquila-sd"
+ACTION=="add|change", KERNEL=="mmcblk[0-9]p[0-9]*", KERNELS=="4fb0000.mmc", SYMLINK+="aquila-sd-part%n"
diff --git a/recipes-core/udev/udev-extraconf_%.bbappend b/recipes-core/udev/udev-extraconf_%.bbappend
deleted file mode 100644
index d746f6b..0000000
--- a/recipes-core/udev/udev-extraconf_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-MOUNT_BASE = "/media"