summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-distro-boot.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-distro-boot.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-distro-boot.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-distro-boot.bb b/recipes-bsp/u-boot/u-boot-distro-boot.bb
index 7830e8e..61bfa03 100644
--- a/recipes-bsp/u-boot/u-boot-distro-boot.bb
+++ b/recipes-bsp/u-boot/u-boot-distro-boot.bb
@@ -12,10 +12,14 @@ SRC_URI = " \
KERNEL_BOOTCMD ??= "bootz"
KERNEL_BOOTCMD:aarch64 ?= "booti"
+KERNEL_DTB_PREFIX ??= ""
+KERNEL_DTB_PREFIX:mx8-generic-bsp ?= "freescale_"
+KERNEL_DTB_PREFIX:k3 ?= "ti_"
+
inherit deploy
do_deploy() {
- sed -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/;s/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \
+ sed -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/;s/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/;s/@@KERNEL_DTB_PREFIX@@/${KERNEL_DTB_PREFIX}/' \
"${WORKDIR}/boot.cmd.in" > boot.cmd
mkimage -T script -C none -n "Distro boot script" -d boot.cmd boot.scr