summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-08-14 13:16:35 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-08-14 13:16:35 +0200
commitfd9e78919a064a927a3dbc8de204d74fe8559066 (patch)
treed6b3aaee0a6d6fc181f6334a5937803cde7bfe0b /recipes-kernel
parent4ba4419239d8a235d80e8197bb73b055476f2d78 (diff)
layer: convert to new override syntax
This is the result of automated script (0.9.3) conversion: +# meta-toradex-distro +vars = vars + ["preempt-rt","tdx","upstream"] +# meta-toradex-* machines +vars = vars + ["apalis-","colibri-","verdin-","tegra124"] +# meta-freescale +vars = vars + ["imx","mx6","mx7","mx8","use-mainline-bsp","use-nxp-bsp"] ../openembedded-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/backports/backports_5.4.bb6
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline.inc6
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_5.4.bb6
3 files changed, 9 insertions, 9 deletions
diff --git a/recipes-kernel/backports/backports_5.4.bb b/recipes-kernel/backports/backports_5.4.bb
index adf0b22..36ba93d 100644
--- a/recipes-kernel/backports/backports_5.4.bb
+++ b/recipes-kernel/backports/backports_5.4.bb
@@ -63,7 +63,7 @@ do_install() {
done
}
-pkg_postinst_${PN} () {
+pkg_postinst:${PN} () {
if [ -z "$D" ]; then
depmod -a ${KERNEL_VERSION}
else
@@ -73,13 +73,13 @@ pkg_postinst_${PN} () {
fi
}
-pkg_postrm_${PN} () {
+pkg_postrm:${PN} () {
if [ -z "$D" ]; then
depmod -a ${KERNEL_VERSION}
fi
}
-FILES_${PN} = " \
+FILES:${PN} = " \
${sysconfdir}/depmod.d/${DEPMOD_CONF} \
${nonarch_base_libdir}/modules/${KERNEL_VERSION}/backports/ \
"
diff --git a/recipes-kernel/linux/linux-toradex-mainline.inc b/recipes-kernel/linux/linux-toradex-mainline.inc
index ffee627..a41992c 100644
--- a/recipes-kernel/linux/linux-toradex-mainline.inc
+++ b/recipes-kernel/linux/linux-toradex-mainline.inc
@@ -1,5 +1,5 @@
SUMMARY = "Toradex mainline Linux kernel"
-SUMMARY_preempt-rt = "Toradex mainline real-Time Linux kernel"
+SUMMARY:preempt-rt = "Toradex mainline real-Time Linux kernel"
SECTION = "kernel"
LICENSE = "GPLv2"
@@ -16,12 +16,12 @@ S = "${WORKDIR}/git"
DEPENDS += "coreutils-native lzop-native"
# Additional file deployed by recent mainline kernels
-FILES_${KERNEL_PACKAGE_NAME}-base += "${nonarch_base_libdir}/modules/${KERNEL_VERSION}/modules.builtin.modinfo"
+FILES:${KERNEL_PACKAGE_NAME}-base += "${nonarch_base_libdir}/modules/${KERNEL_VERSION}/modules.builtin.modinfo"
KERNEL_CONFIG_NAME ?= "${KERNEL_PACKAGE_NAME}-config-${KERNEL_ARTIFACT_NAME}"
KERNEL_CONFIG_LINK_NAME ?= "${KERNEL_PACKAGE_NAME}-config"
-do_deploy_append() {
+do_deploy:append() {
cp -a ${B}/.config ${DEPLOYDIR}/${KERNEL_CONFIG_NAME}
ln -sf ${KERNEL_CONFIG_NAME} ${DEPLOYDIR}/${KERNEL_CONFIG_LINK_NAME}
}
diff --git a/recipes-kernel/linux/linux-toradex-mainline_5.4.bb b/recipes-kernel/linux/linux-toradex-mainline_5.4.bb
index 77ec304..08149bd 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_5.4.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_5.4.bb
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-5.4:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-5.4:"
LINUX_VERSION ?= "5.4.129"
PV = "${LINUX_VERSION}+git${SRCPV}"
@@ -12,7 +12,7 @@ KBRANCH = "toradex_5.4.y"
require recipes-kernel/linux/linux-toradex-mainline.inc
-SRC_URI_append_preempt-rt = " \
+SRC_URI:append:preempt-rt = " \
${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.4/patch-5.4.129-rt61.patch.xz;name=rt-patch \
file://preempt-rt.scc \
file://preempt-rt-less-latency.scc \
@@ -24,6 +24,6 @@ SRC_URI[rt-patch.sha256sum] = "f8ddc34c7765bb78c9f44c4e41dae7d4196c87201212ab4ec
KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains('COMBINED_FEATURES', 'usbgadget', ' libcomposite', '',d)}"
KBUILD_DEFCONFIG ?= "toradex-imx_v6_v7_defconfig"
-KBUILD_DEFCONFIG_apalis-tk1 ?= "tegra_defconfig"
+KBUILD_DEFCONFIG:apalis-tk1 ?= "tegra_defconfig"
export DTC_FLAGS = "-@"