summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAishwarya Kothari <aishwarya.kothari@toradex.com>2023-05-22 11:51:19 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-06-28 11:14:21 +0200
commitdaa126430a406adb11df1ea468ccc8bccc393114 (patch)
treed2184b8b4a3483582429fea2a5cb54f3378ecb51 /recipes-kernel
parent8d19a56b64c27027f9c13340bae40bffbf9cbe65 (diff)
linux-toradex-mainline: fix hdmi-csi bridge with iMX6
Revert 1f391df446077d62514ee29f75970dff3d55a432 This reverted commit breaks the async subdevice probing that is needed by TC358743 HDMI to MIPI-CSI2 bridge on Apalis iMX6. See [1] for details. The V4L2 async framework for the imx6 seem to be fixed by [2] patch series, that it is not yet merged. While waiting for this patch series to be merged we revert this single commit. [1] https://lore.kernel.org/all/8360125.31r3eYUQgx@steina-w/ [2] https://lore.kernel.org/all/20230525091615.2324824-1-sakari.ailus@linux.intel.com/ Related-to: ELB-5141 Signed-off-by: Aishwarya Kothari <aishwarya.kothari@toradex.com> (cherry picked from commit 4b9dee855fe97fe7d17209202ffd5503fa1878d7)
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-media-v4l2-async-Use-endpoints-in-__v4l2_asyn.patch40
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_git.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-media-v4l2-async-Use-endpoints-in-__v4l2_asyn.patch b/recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-media-v4l2-async-Use-endpoints-in-__v4l2_asyn.patch
new file mode 100644
index 0000000..a0575ad
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-media-v4l2-async-Use-endpoints-in-__v4l2_asyn.patch
@@ -0,0 +1,40 @@
+From 3557195151f8a5de785dc75c26aea30288473c5b Mon Sep 17 00:00:00 2001
+From: Aishwarya Kothari <aishwaryakothari75@gmail.com>
+Date: Mon, 22 May 2023 11:17:34 +0200
+Subject: [PATCH] Revert "media: v4l2-async: Use endpoints in
+ __v4l2_async_nf_add_fwnode_remote()"
+
+linux-toradex-mainline: fix hdmi-csi bridge with imx6
+
+Revert f446077d62514ee29f75970dff3d55a432.
+
+This reverted commit breaks the async subdevice probing that is needed
+by TC358743 HDMI to MIPI-CSI2 bridge on Apalis iMX6. See [1] for details.
+
+The V4L2 async framework for the iMX6 seem to be fixed by [2]
+patch series, that it is not yet merged.
+While waiting for this patch series to be merged we revert this single commit.
+
+[1] https://lore.kernel.org/all/8360125.31r3eYUQgx@steina-w/
+[2] https://lore.kernel.org/all/20230525091615.2324824-1-sakari.ailus@linux.intel.com/
+
+---
+ drivers/media/v4l2-core/v4l2-async.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/media/v4l2-core/v4l2-async.c b/drivers/media/v4l2-core/v4l2-async.c
+index 008a2a3e312e..0c88d2594671 100644
+--- a/drivers/media/v4l2-core/v4l2-async.c
++++ b/drivers/media/v4l2-core/v4l2-async.c
+@@ -713,7 +713,7 @@ __v4l2_async_nf_add_fwnode_remote(struct v4l2_async_notifier *notif,
+ struct v4l2_async_subdev *asd;
+ struct fwnode_handle *remote;
+
+- remote = fwnode_graph_get_remote_endpoint(endpoint);
++ remote = fwnode_graph_get_remote_port_parent(endpoint);
+ if (!remote)
+ return ERR_PTR(-ENOTCONN);
+
+--
+2.34.1
+
diff --git a/recipes-kernel/linux/linux-toradex-mainline_git.bb b/recipes-kernel/linux/linux-toradex-mainline_git.bb
index c2902e6..f559ea3 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_git.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_git.bb
@@ -31,6 +31,7 @@ SRC_URI:append = " \
file://0002-drivers-chipidea-disable-runtime-pm-for-imx6ul.patch \
file://0001-media-v4l2-async-fix-binding-async-subdevs-with-mult.patch \
file://0002-media-i2c-ov5640-Implement-get_mbus_config.patch \
+ file://0001-Revert-media-v4l2-async-Use-endpoints-in-__v4l2_asyn.patch \
"
LINUX_VERSION ?= "6.3-rc"