summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-11-09 12:48:43 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2022-12-09 14:19:02 +0100
commita91cc196ac076c981638cace60bc33af7b82dcc6 (patch)
treefacd8186d220d8776bf71fc2aaa58d11d26f5102 /recipes-kernel
parent465ee7cac66246893d66e4042b53b9d94c9cf97b (diff)
linux-toradex-mainline: split out rt kernel
Split out the real time kernel build from the existing linux-toradex-mainline recipe. This simplifies updateing the srcrev automated and makes it clearer what is being built. Releated-to: ELB-4868 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit b6a453bdcd4841f44dc6c86f2abd06fe97936580) Conflicts: recipes-kernel/linux/linux-toradex-mainline_git.bb
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-rt_git.bb17
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_git.bb18
2 files changed, 17 insertions, 18 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb b/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
new file mode 100644
index 0000000..12ac6ae
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
@@ -0,0 +1,17 @@
+require recipes-kernel/linux/linux-toradex-mainline_git.bb
+
+SUMMARY = "Toradex mainline real-time Linux kernel"
+# To build the RT kernel we use the RT kernel git repo rather than applying
+# the RT patch on top of a vanilla kernel.
+
+LINUX_REPO = "git://git.kernel.org/pub/scm/linux/kernel/git/rt/linux-rt-devel.git"
+LINUX_VERSION ?= "6.0.5-rt14"
+LINUX_VERSION:use-head-next ?= "6.0-rt"
+KBRANCH = "linux-6.0.y-rt"
+SRCREV_machine = "040e3123e9d93721de64a3df726871b57af204e9"
+SRCREV_machine:use-head-next = "${AUTOREV}"
+
+SRC_URI:append = " \
+ file://preempt-rt.scc \
+ file://preempt-rt-less-latency.scc \
+"
diff --git a/recipes-kernel/linux/linux-toradex-mainline_git.bb b/recipes-kernel/linux/linux-toradex-mainline_git.bb
index 766839f..de01fb8 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_git.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_git.bb
@@ -1,5 +1,4 @@
SUMMARY = "Toradex mainline Linux kernel"
-SUMMARY:preempt-rt = "Toradex mainline real-time Linux kernel"
SECTION = "kernel"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM ?= "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
@@ -67,20 +66,3 @@ do_deploy:append() {
cp -a ${B}/.config ${DEPLOYDIR}/${KERNEL_CONFIG_NAME}
ln -sf ${KERNEL_CONFIG_NAME} ${DEPLOYDIR}/${KERNEL_CONFIG_LINK_NAME}
}
-
-#######################################################################
-
-LINUX_REPO:preempt-rt = "git://git.kernel.org/pub/scm/linux/kernel/git/rt/linux-rt-devel.git"
-LINUX_VERSION:preempt-rt ?= "6.0.5-rt14"
-LINUX_VERSION:use-head-next:preempt-rt ?= "6.0-rt"
-KBRANCH:preempt-rt = "linux-6.0.y-rt"
-KBRANCH:use-head-next:preempt-rt = "linux-6.0.y-rt"
-SRCREV_machine:preempt-rt = "040e3123e9d93721de64a3df726871b57af204e9"
-SRCREV_machine:preempt-rt:use-head-next = "${AUTOREV}"
-
-SRC_URI:append:preempt-rt = " \
- file://preempt-rt.scc \
- file://preempt-rt-less-latency.scc \
-"
-
-#######################################################################