summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-08-22 10:09:52 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2023-08-22 17:17:31 +0200
commit36705df6b7f3df7d913bc5dcc7299d14d9cd5b9f (patch)
treecedf874978dd291115e7a20ee758593132b45e98 /recipes-kernel
parent1ed5e0041a950758b7f9cfc774fc1dad11db08cc (diff)
toradex-kernel: move deployment of .config into class
After building the kernel we want the used config being deployed. This is already implemented for the linux-toradex-mainline recipe, however the downstream vendor based kernels to not deploy the config. Move the functionality to a class and inherit that in the mainline kernel recipe to allow reusing the class in the downstream kernel recipes. Related-to: ELB-5149 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_git.bb10
1 files changed, 1 insertions, 9 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline_git.bb b/recipes-kernel/linux/linux-toradex-mainline_git.bb
index 05a53f4..e9bc377 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_git.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_git.bb
@@ -47,20 +47,12 @@ KCONFIG_MODE="--alldefconfig"
# Load USB functions configurable through configfs (CONFIG_USB_CONFIGFS)
KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains('COMBINED_FEATURES', 'usbgadget', ' libcomposite', '',d)}"
-inherit kernel-yocto kernel pkgconfig toradex-kernel-localversion
+inherit kernel-yocto kernel pkgconfig toradex-kernel-deploy-config toradex-kernel-localversion
# Additional file deployed by recent mainline kernels
FILES:${KERNEL_PACKAGE_NAME}-base += "${nonarch_base_libdir}/modules/${KERNEL_VERSION}/modules.builtin.modinfo"
-KERNEL_CONFIG_NAME ?= "${KERNEL_PACKAGE_NAME}-config-${KERNEL_ARTIFACT_NAME}"
-KERNEL_CONFIG_LINK_NAME ?= "${KERNEL_PACKAGE_NAME}-config"
-
export DTC_FLAGS = "-@"
# kconfiglib.KconfigError: init/Kconfig:70: error: couldn't parse 'default $(shell,$(srctree)/scripts/rust-version.sh $(RUSTC))': macro expanded to blank string
do_kernel_configcheck[noexec] = "1"
-
-do_deploy:append() {
- cp -a ${B}/.config ${DEPLOYDIR}/${KERNEL_CONFIG_NAME}
- ln -sf ${KERNEL_CONFIG_NAME} ${DEPLOYDIR}/${KERNEL_CONFIG_LINK_NAME}
-}