summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-07-18 13:33:38 +0200
committerMing Liu <ming.liu@toradex.int>2022-07-18 16:21:49 +0000
commit1b08915fda2af68c2ad4d3b0ec488be42c156816 (patch)
tree770e1217f8e9907a64c96f89735158ae26f3f3f6 /recipes-kernel
parentb650bf136ce4a8a75b9a8c1d8426170348c21b7c (diff)
linux-toradex-mainline: change to use LZ4 compression instead of LZO
There are two reasons for doing this: - LZ4 compression is an extremely fast decoder that can improve booting time, some research reference: https://events.static.linuxfound.org/sites/events/files/lcjpcojp13_klee.pdf - The lzop recipe has been moved from OE to meta-openembedded layer, see: https://lore.kernel.org/openembedded-core/20220524152401.1663317-9-ross.burton@arm.com/ we should keep involving in as less dependencies as we can from meta-openembedded. Related-to: ELB-4534 Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-git/defconfig2
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/defconfig b/recipes-kernel/linux/linux-toradex-mainline-git/defconfig
index c6f7b05..00320a5 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-git/defconfig
+++ b/recipes-kernel/linux/linux-toradex-mainline-git/defconfig
@@ -1,4 +1,4 @@
-CONFIG_KERNEL_LZO=y
+CONFIG_KERNEL_LZ4=y
CONFIG_SYSVIPC=y
CONFIG_NO_HZ=y
CONFIG_HIGH_RES_TIMERS=y
diff --git a/recipes-kernel/linux/linux-toradex-mainline_git.bb b/recipes-kernel/linux/linux-toradex-mainline_git.bb
index 471a00d..5e1ea6f 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_git.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM ?= "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-git:"
-DEPENDS += "coreutils-native lzop-native"
+DEPENDS += "coreutils-native"
# yaml and dtschema are required for 5.16+ device tree validation, libyaml is checked
# via pkgconfig, so must always be present, but we can wrap the others to make them